diff mbox series

mvebu/kernel: promote 5.10 to stable

Message ID 20210907202306.38794-1-rsalvaterra@gmail.com
State Superseded
Headers show
Series mvebu/kernel: promote 5.10 to stable | expand

Commit Message

Rui Salvaterra Sept. 7, 2021, 8:23 p.m. UTC
It's been brewing on my cortexa9 subtarget (Turris Omnia) for months. Perfectly
stable.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 target/linux/mvebu/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Josef Schlehofer Sept. 7, 2021, 8:44 p.m. UTC | #1
Ășt 7. 9. 2021 v 22:23 odesĂ­latel Rui Salvaterra <rsalvaterra@gmail.com> napsal:
>
> It's been brewing on my cortexa9 subtarget (Turris Omnia) for months. Perfectly
> stable.
>
> Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Tested-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
> ---
>  target/linux/mvebu/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
> index 3737a4aa23..6c2280cc79 100644
> --- a/target/linux/mvebu/Makefile
> +++ b/target/linux/mvebu/Makefile
> @@ -9,7 +9,7 @@ BOARDNAME:=Marvell EBU Armada
>  FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
>  SUBTARGETS:=cortexa9 cortexa53 cortexa72
>
> -KERNEL_PATCHVER:=5.4
> +KERNEL_PATCHVER:=5.10
>  KERNEL_TESTING_PATCHVER:=5.10
>
>  include $(INCLUDE_DIR)/target.mk
> --
> 2.33.0
>
Daniel Golle Sept. 7, 2021, 9:08 p.m. UTC | #2
On Tue, Sep 07, 2021 at 09:23:06PM +0100, Rui Salvaterra wrote:
> It's been brewing on my cortexa9 subtarget (Turris Omnia) for months. Perfectly
> stable.
> 
> Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
> ---
>  target/linux/mvebu/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
> index 3737a4aa23..6c2280cc79 100644
> --- a/target/linux/mvebu/Makefile
> +++ b/target/linux/mvebu/Makefile
> @@ -9,7 +9,7 @@ BOARDNAME:=Marvell EBU Armada
>  FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
>  SUBTARGETS:=cortexa9 cortexa53 cortexa72
>  
> -KERNEL_PATCHVER:=5.4
> +KERNEL_PATCHVER:=5.10
>  KERNEL_TESTING_PATCHVER:=5.10

I'd remove the KERNEL_TESTING_PATCHVER line then until we add 5.14 or
whatever it's going to be.
Rui Salvaterra Sept. 7, 2021, 9:31 p.m. UTC | #3
Hi, Daniel,

On Tue, 7 Sept 2021 at 22:09, Daniel Golle <daniel@makrotopia.org> wrote:
>
> I'd remove the KERNEL_TESTING_PATCHVER line then until we add 5.14 or
> whatever it's going to be.

Sure, I didn't know what the usual procedure was, so I just mimicked aparcar. ;)
V2 coming up.

Thanks,
Rui
Paul Spooren Sept. 7, 2021, 9:36 p.m. UTC | #4
On 9/7/21 11:31, Rui Salvaterra wrote:
> Hi, Daniel,
>
> On Tue, 7 Sept 2021 at 22:09, Daniel Golle <daniel@makrotopia.org> wrote:
>> I'd remove the KERNEL_TESTING_PATCHVER line then until we add 5.14 or
>> whatever it's going to be.
> Sure, I didn't know what the usual procedure was, so I just mimicked aparcar. ;)
> V2 coming up.

This seems to be an ongoing thing, some add it and some remove it, I'm 
happy to make this consistent:

* Remove KERNEL_TESTING_PATCHVER when promoting

or

* Set KERNEL_{,TESTING}_PATCHVER to the same value until a new testing 
Kernel is added

I'd prefer the former since it removes the feature flag 
`testing-kernel`, therefore I'd update my patch and we should do that 
for all further *Kernel promotions*. Objections?
Rui Salvaterra Sept. 7, 2021, 9:40 p.m. UTC | #5
Hi, Paul,

On Tue, 7 Sept 2021 at 22:37, Paul Spooren <mail@aparcar.org> wrote:
>
> This seems to be an ongoing thing, some add it and some remove it, I'm
> happy to make this consistent:
>
> * Remove KERNEL_TESTING_PATCHVER when promoting
>
> or
>
> * Set KERNEL_{,TESTING}_PATCHVER to the same value until a new testing
> Kernel is added
>
> I'd prefer the former since it removes the feature flag
> `testing-kernel`, therefore I'd update my patch and we should do that
> for all further *Kernel promotions*. Objections?

Agreed, I also prefer the former. Should cause less confusion when
configuring, at least.

Thanks,
Rui
Andre Heider Sept. 8, 2021, 5:34 a.m. UTC | #6
On 07/09/2021 23:40, Rui Salvaterra wrote:
> Hi, Paul,
> 
> On Tue, 7 Sept 2021 at 22:37, Paul Spooren <mail@aparcar.org> wrote:
>>
>> This seems to be an ongoing thing, some add it and some remove it, I'm
>> happy to make this consistent:
>>
>> * Remove KERNEL_TESTING_PATCHVER when promoting
>>
>> or
>>
>> * Set KERNEL_{,TESTING}_PATCHVER to the same value until a new testing
>> Kernel is added
>>
>> I'd prefer the former since it removes the feature flag
>> `testing-kernel`, therefore I'd update my patch and we should do that
>> for all further *Kernel promotions*. Objections?
> 
> Agreed, I also prefer the former. Should cause less confusion when
> configuring, at least.

That has been solved fwiw, for the record:

commit cf6f01c0e69a31afc6c5f384405ace51e03fe481
Author: David Bauer <mail@david-bauer.net>
Date:   Tue Jul 7 10:32:09 2020 +0200

     build: conditionally enable testing-kernel feature

     Only enable the testing-kernel feature for the target when the testing
     kernel version does not match the stable kernel version.

     This way, the option for building the testing kernel in the build 
config
     menu is only exposed when there's a testing kernel available.

     Signed-off-by: David Bauer <mail@david-bauer.net>
     Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Adrian Schmutzler Sept. 11, 2021, 6:02 p.m. UTC | #7
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Paul Spooren
> Sent: Dienstag, 7. September 2021 23:37
> To: Rui Salvaterra <rsalvaterra@gmail.com>; Daniel Golle
> <daniel@makrotopia.org>
> Cc: openwrt-devel@lists.openwrt.org; pepe.schlehofer@gmail.com;
> klaus.kudielka@gmail.com; tmn505@gmail.com; hauke@hauke-m.de
> Subject: Re: [PATCH] mvebu/kernel: promote 5.10 to stable
> 
> 
> On 9/7/21 11:31, Rui Salvaterra wrote:
> > Hi, Daniel,
> >
> > On Tue, 7 Sept 2021 at 22:09, Daniel Golle <daniel@makrotopia.org>
wrote:
> >> I'd remove the KERNEL_TESTING_PATCHVER line then until we add 5.14 or
> >> whatever it's going to be.
> > Sure, I didn't know what the usual procedure was, so I just mimicked
> > aparcar. ;)
> > V2 coming up.
> 
> This seems to be an ongoing thing, some add it and some remove it, I'm
> happy to make this consistent:
> 
> * Remove KERNEL_TESTING_PATCHVER when promoting
> 
> or
> 
> * Set KERNEL_{,TESTING}_PATCHVER to the same value until a new testing
> Kernel is added

Some prefer not having to add it again, some prefer to have it removed.

In any case, lines are directly next to each other, so nobody should have a
problem with finding out that both are the same if it's kept.

Since there have been different opinions expressed by committers (e.g. I
prefer to keep it), we would technically need a vote on this.
However, I think this is definitely way too unimportant to vote on it. So
I'd just leave it to the submitters' and committers' taste.

Best

Adrian


> 
> I'd prefer the former since it removes the feature flag `testing-kernel`,
> therefore I'd update my patch and we should do that for all further
*Kernel
> promotions*. Objections?
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 3737a4aa23..6c2280cc79 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -9,7 +9,7 @@  BOARDNAME:=Marvell EBU Armada
 FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
 SUBTARGETS:=cortexa9 cortexa53 cortexa72
 
-KERNEL_PATCHVER:=5.4
+KERNEL_PATCHVER:=5.10
 KERNEL_TESTING_PATCHVER:=5.10
 
 include $(INCLUDE_DIR)/target.mk