diff mbox series

[1/6] busybox: fix compilation with GCC 10

Message ID 20210815105119.3035569-2-stijn@linux-ipv6.be
State Accepted
Delegated to: Stijn Tintel
Headers show
Series use binutils 2.36.1 and gcc 10 by default | expand

Commit Message

Stijn Tintel Aug. 15, 2021, 10:51 a.m. UTC
When compiling busybox with GCC 10 and CONFIG_PKG_ASLR_PIE_ALL=y, there
are hundreds of errors like:

relocation R_MIPS16_26 against `xzalloc' cannot be used when making a
shared object; recompile with -fPIC

Simply solve this by no longer disabling PKG_ASLR_PIE, so that $(FPIC)
is properly added to the CFLAGS and LDFLAGS.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---
 package/utils/busybox/Makefile | 3 ---
 1 file changed, 3 deletions(-)
diff mbox series

Patch

diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 32f0d2c755..76a1de33b7 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -18,9 +18,6 @@  PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
 PKG_BUILD_PARALLEL:=1
 PKG_CHECK_FORMAT_SECURITY:=0
 
-#Busybox use it's own PIE config flag and LDFLAGS are used with ld, not gcc.
-PKG_ASLR_PIE:=0
-
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
 PKG_CPE_ID:=cpe:/a:busybox:busybox