diff mbox series

[19.07] tools/mklibs: Fix compile with GCC 11

Message ID 20210516215720.3812015-1-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series [19.07] tools/mklibs: Fix compile with GCC 11 | expand

Commit Message

Hauke Mehrtens May 16, 2021, 9:57 p.m. UTC
GCC 11 defaults to C++17, but mklibs does not compile when using the
C++17 standard. This patch switches back to the gnu++98 version like
done in master commit 9437012b9ee4 ("tools/mklibs: update to 0.1.44 and
convert to Python 3")

This fixes the following compile error message:
elf.hpp:52:56: error: ISO C++17 does not allow dynamic exception specifications
   52 |       const section &get_section(unsigned int i) const throw (std::out_of_range) { return *sections.at(i); };

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 tools/mklibs/Makefile | 1 +
 1 file changed, 1 insertion(+)

Comments

Bas Mevissen May 17, 2021, 8:35 a.m. UTC | #1
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
On 2021-05-16 23:57, Hauke Mehrtens wrote:
> GCC 11 defaults to C++17, but mklibs does not compile when using the
> C++17 standard. This patch switches back to the gnu++98 version like
> done in master commit 9437012b9ee4 ("tools/mklibs: update to 0.1.44 and
> convert to Python 3")
> 
> This fixes the following compile error message:
> elf.hpp:52:56: error: ISO C++17 does not allow dynamic exception 
> specifications
>    52 |       const section &get_section(unsigned int i) const throw
> (std::out_of_range) { return *sections.at(i); };
> 
> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
> ---
>  tools/mklibs/Makefile | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
> index 507c2fd394..8826840524 100644
> --- a/tools/mklibs/Makefile
> +++ b/tools/mklibs/Makefile
> @@ -18,6 +18,7 @@ HOST_FIXUP:=autoreconf
>  include $(INCLUDE_DIR)/host-build.mk
> 
>  HOST_CFLAGS += -I$(CURDIR)/include
> +HOST_CPPFLAGS += -std=gnu++98
> 
>  define Host/Install
>         $(INSTALL_BIN) \

Thanks, this probably the best thing to do for 19.07. I overlooked the 
change above in the 9437012b9ee4 commit and assumed the mklibs 0.1.44 
was gnu++17 compliant.

Bas.
diff mbox series

Patch

diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
index 507c2fd394..8826840524 100644
--- a/tools/mklibs/Makefile
+++ b/tools/mklibs/Makefile
@@ -18,6 +18,7 @@  HOST_FIXUP:=autoreconf
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += -I$(CURDIR)/include
+HOST_CPPFLAGS += -std=gnu++98
 
 define Host/Install
        $(INSTALL_BIN) \