diff mbox series

toolchain/gdb: fix compilation with ccache

Message ID 20210405013230.232818-1-rosenp@gmail.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series toolchain/gdb: fix compilation with ccache | expand

Commit Message

Rosen Penev April 5, 2021, 1:32 a.m. UTC
For some reason, one of the configure checks results in some infinite
loop and ends up spawning endless gcc processes, causing OOM. Just pass
a configure var to avoid it.

Same fix as 6e23813c1ed7494a9da3b5e59cfcafd71097c420

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 toolchain/gdb/Makefile | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 3bcc9d1238..05e3c7de3c 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,6 +22,7 @@  HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 HOST_CONFIGURE_VARS += \
+	acx_cv_cc_gcc_supports_ada=false \
 	gdb_cv_func_sigsetjmp=yes
 
 HOST_CONFIGURE_ARGS = \