diff mbox series

[1/2] package: store SourceName in Packages index

Message ID 20210308042852.1263328-2-mail@aparcar.org
State Rejected
Delegated to: Paul Spooren
Headers show
Series determineable package name with ABIVersions | expand

Commit Message

Paul Spooren March 8, 2021, 4:28 a.m. UTC
With the existence of ABI versions there is no clean way to determine
the package name without an attached ABI version. The Packages index is
stored on device to know what packages are installed.

As SourceName is filtered out the real package names are unknown to a
running device. This becomes a problem if a user tries toexport
installed packages via `ubus call rpcd-sys packagelist` which would
return package names including the ABI version. Trying to find these
packages in a later release with changes ABI version is impossible.

This patch stops filtering out the SourceName so it is available on
device.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 package/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/Makefile b/package/Makefile
index a89a6068fa..802100838c 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -87,7 +87,7 @@  $(curdir)/index: FORCE
 		cd $$d || continue; \
 		$(SCRIPT_DIR)/apk-make-index.sh . 2>&1; \
 		$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
-		grep -vE '^(Maintainer|LicenseFiles|Source|SourceName|Require|SourceDateEpoch)' Packages.manifest > Packages; \
+		grep -vE '^(Maintainer|LicenseFiles|Source:|Require|SourceDateEpoch)' Packages.manifest > Packages; \
 		case "$$(((64 + $$(stat -L -c%s Packages)) % 128))" in 110|111) \
 			$(call ERROR_MESSAGE,WARNING: Applying padding in $$d/Packages to workaround usign SHA-512 bug!); \
 			{ echo ""; echo ""; } >> Packages;; \