diff mbox series

[v2] acx-mac80211: replace dead URLs with OpenWrt CDN

Message ID 20210206051118.641266-1-ilya.lipnitskiy@gmail.com
State Accepted
Delegated to: Paul Spooren
Headers show
Series [v2] acx-mac80211: replace dead URLs with OpenWrt CDN | expand

Commit Message

Ilya Lipnitskiy Feb. 6, 2021, 5:11 a.m. UTC
erley.org no longer exists; attempting to connect to it during package
download results in lengthy timeouts. Use the new OpenWrt CDN alias to
download from reliable OpenWrt mirrors.

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
---
 package/kernel/acx-mac80211/Makefile | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

Comments

Paul Spooren Feb. 7, 2021, 8:26 a.m. UTC | #1
Hi Ilya,

thanks for the quick fixup! One comment below.

On Fri Feb 5, 2021 at 7:11 PM HST, Ilya Lipnitskiy wrote:
> erley.org no longer exists; attempting to connect to it during package
> download results in lengthy timeouts. Use the new OpenWrt CDN alias to
> download from reliable OpenWrt mirrors.
>
> Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
> ---
> package/kernel/acx-mac80211/Makefile | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/package/kernel/acx-mac80211/Makefile
> b/package/kernel/acx-mac80211/Makefile
> index a04b9e28ba..8bb84e5a6a 100644
> --- a/package/kernel/acx-mac80211/Makefile
> +++ b/package/kernel/acx-mac80211/Makefile
> @@ -112,55 +112,55 @@ endef
>  
> define Download/tiacx100
> FILE:=tiacx100
> - URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
> + URL:=@OPENWRT
> HASH:=4f05913c940c2455b267545b12d93ad81fa5eebb0cbee22a2c7588c50525b4f0
> endef
>  
> define Download/tiacx100r0d
> FILE:=tiacx100r0D
> - URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
> + URL:=@OPENWRT
> HASH:=6a4a7fbb24a328a88261bc2a507b2a0bf63c91e831e3f1a8caa4f6599b2215e6
> endef
>  
> define Download/tiacx100r11
> FILE:=tiacx100r11
> - URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
> + URL:=@OPENWRT
> HASH:=e005a93a0b463e01edba2b79038b54c29a7932efee61c851a2ac644b8a4e5dd4
> endef
>  
> define Download/tiacx100r15
> FILE:=tiacx100r15
> - URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
> + URL:=@OPENWRT
> HASH:=c6f40bead5ef45720e2d72bbe4d998367c2c7857eb7716234aedeb2ad98bcdde
> endef
>  
> define Download/tiacx111c16
> FILE:=tiacx111c16
> - URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
> + URL:=@OPENWRT
> HASH:=cc6108d577ebc55b924ff6bab44eeee3456d284c63819277cb5460338b2f1bd7
> endef
>  
> define Download/tiacx111c16_1
> FILE:=tiacx111c16_1.2.1_34
> - URL:=http://sites.google.com/site/atorkhov/files/
> + URL:=@OPENWRT

This file is still available, does the download fail as well?

> HASH:=672ed9d02565ab44da450c52f0ced3be99a3a3901f73454455da8e1f98ada220
> endef
>  
> define Download/tiacx111c17
> FILE:=tiacx111c17
> - URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
> + URL:=@OPENWRT
> HASH:=2bb900a5886dbea2d3504623d9f3ac8abbb2e9fdfcf0fe233e77951dff748a40
> endef
>  
> define Download/tiacx111c19
> FILE:=tiacx111c19
> - URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
> + URL:=@OPENWRT
> HASH:=383d86a8cfddf92400d661b4e43a9b855350fa656edd4f75b4aff7fab2d00e90
> endef
>  
> define Download/tiacx111usbc1b
> FILE:=tiacx111usbc1B
> - URL:=http://acx100.erley.org/fw/acx111_2.4.0.70-USB/
> + URL:=@OPENWRT
> HASH:=f3c9e574de7073014ab6eef9a0f6412c53ae521b67723360af753c41401ed4d5
> endef
>  
> --
> 2.30.0
Ilya Lipnitskiy Feb. 7, 2021, 7:53 p.m. UTC | #2
Hi Paul,

> > define Download/tiacx111c16_1
> > FILE:=tiacx111c16_1.2.1_34
> > - URL:=http://sites.google.com/site/atorkhov/files/
> > + URL:=@OPENWRT
>
> This file is still available, does the download fail as well?
>
This one still works, but being a personal google website didn't seem
as good as just using the CDN consistently across all files. I can
keep this one site untouched, if you wish. Let me know.

Ilya
Paul Spooren Feb. 7, 2021, 9:29 p.m. UTC | #3
On Sun Feb 7, 2021 at 9:53 AM HST, Ilya Lipnitskiy wrote:
> Hi Paul,
>
> > > define Download/tiacx111c16_1
> > > FILE:=tiacx111c16_1.2.1_34
> > > - URL:=http://sites.google.com/site/atorkhov/files/
> > > + URL:=@OPENWRT
> >
> > This file is still available, does the download fail as well?
> >
> This one still works, but being a personal google website didn't seem
> as good as just using the CDN consistently across all files. I can
> keep this one site untouched, if you wish. Let me know.

Agree, I pushed your changes. Thank you.

>
> Ilya
diff mbox series

Patch

diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
index a04b9e28ba..8bb84e5a6a 100644
--- a/package/kernel/acx-mac80211/Makefile
+++ b/package/kernel/acx-mac80211/Makefile
@@ -112,55 +112,55 @@  endef
 
 define Download/tiacx100
 	FILE:=tiacx100
-	URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
+	URL:=@OPENWRT
 	HASH:=4f05913c940c2455b267545b12d93ad81fa5eebb0cbee22a2c7588c50525b4f0
 endef
 
 define Download/tiacx100r0d
 	FILE:=tiacx100r0D
-	URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
+	URL:=@OPENWRT
 	HASH:=6a4a7fbb24a328a88261bc2a507b2a0bf63c91e831e3f1a8caa4f6599b2215e6
 endef
 
 define Download/tiacx100r11
 	FILE:=tiacx100r11
-	URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
+	URL:=@OPENWRT
 	HASH:=e005a93a0b463e01edba2b79038b54c29a7932efee61c851a2ac644b8a4e5dd4
 endef
 
 define Download/tiacx100r15
 	FILE:=tiacx100r15
-	URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
+	URL:=@OPENWRT
 	HASH:=c6f40bead5ef45720e2d72bbe4d998367c2c7857eb7716234aedeb2ad98bcdde
 endef
 
 define Download/tiacx111c16
 	FILE:=tiacx111c16
-	URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
+	URL:=@OPENWRT
 	HASH:=cc6108d577ebc55b924ff6bab44eeee3456d284c63819277cb5460338b2f1bd7
 endef
 
 define Download/tiacx111c16_1
 	FILE:=tiacx111c16_1.2.1_34
-	URL:=http://sites.google.com/site/atorkhov/files/
+	URL:=@OPENWRT
 	HASH:=672ed9d02565ab44da450c52f0ced3be99a3a3901f73454455da8e1f98ada220
 endef
 
 define Download/tiacx111c17
 	FILE:=tiacx111c17
-	URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
+	URL:=@OPENWRT
 	HASH:=2bb900a5886dbea2d3504623d9f3ac8abbb2e9fdfcf0fe233e77951dff748a40
 endef
 
 define Download/tiacx111c19
 	FILE:=tiacx111c19
-	URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
+	URL:=@OPENWRT
 	HASH:=383d86a8cfddf92400d661b4e43a9b855350fa656edd4f75b4aff7fab2d00e90
 endef
 
 define Download/tiacx111usbc1b
 	FILE:=tiacx111usbc1B
-	URL:=http://acx100.erley.org/fw/acx111_2.4.0.70-USB/
+	URL:=@OPENWRT
 	HASH:=f3c9e574de7073014ab6eef9a0f6412c53ae521b67723360af753c41401ed4d5
 endef