diff mbox series

[1/2] realtek: use vendor-specific magic for ZyXEL

Message ID 20210123100812.5158-2-bjorn@mork.no
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [1/2] realtek: use vendor-specific magic for ZyXEL | expand

Commit Message

Bjørn Mork Jan. 23, 2021, 10:08 a.m. UTC
The stock firmware of the ZyXEL GS1900 series use a non-standard
u-image magic.  This is not enforced by the stock u-boot, which is
why we could boot images with the default magic.  The flash
management application of the stock firmware will however verify
the magic, and refuse any image with another value.

Convert to vendor-specific value to get flash management support
in stock firmware, including the ability to upgrade to OpenWrt
directly from stock web UI.

Signed-off-by: Bjørn Mork <bjorn@mork.no>
---
 target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi | 3 ++-
 target/linux/realtek/image/Makefile                | 3 +++
 2 files changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi b/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
index 5f06339d13bf..c4441ec30eef 100644
--- a/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
+++ b/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
@@ -92,7 +92,8 @@ 
 			partition@b260000 {
 				label = "firmware";
 				reg = <0x260000 0x6d0000>;
-				compatible = "denx,uimage";
+				compatible = "openwrt,uimage", "denx,uimage";
+				openwrt,ih-magic = <0x83800000>;
 			};
 			partition@930000 {
 				label = "runtime2";
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 1251b47c933d..c0ae8be36d98 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -70,6 +70,7 @@  define Device/zyxel_gs1900-10hp
   IMAGE_SIZE := 6976k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := GS1900-10HP
+  UIMAGE_MAGIC := 0x83800000
 endef
 TARGET_DEVICES += zyxel_gs1900-10hp
 
@@ -80,6 +81,7 @@  define Device/zyxel_gs1900-8hp-v1
   DEVICE_MODEL := GS1900-8HP
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES += lua-rs232
+  UIMAGE_MAGIC := 0x83800000
 endef
 TARGET_DEVICES += zyxel_gs1900-8hp-v1
 
@@ -90,6 +92,7 @@  define Device/zyxel_gs1900-8hp-v2
   DEVICE_MODEL := GS1900-8HP
   DEVICE_VARIANT := v2
   DEVICE_PACKAGES += lua-rs232
+  UIMAGE_MAGIC := 0x83800000
 endef
 TARGET_DEVICES += zyxel_gs1900-8hp-v2