diff mbox series

[2/6] ramips: remove generic profiles

Message ID 20210122105244.4079-2-freifunk@adrianschmutzler.de
State Accepted
Delegated to: Adrian Schmutzler
Headers show
Series [1/6] ath79: remove generic profiles | expand

Commit Message

Adrian Schmutzler Jan. 22, 2021, 10:52 a.m. UTC
On a platform with many very different devices, like found on ramips,
the generic profiles seem like remnants of the past that do not
have a real use anymore.

Remove them to have one thing less to maintain.

Actually, rt288x didn't have a default profile in the first place.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 .../ramips/mt7620/profiles/00-default.mk      | 17 -----------------
 .../ramips/mt7621/profiles/00-default.mk      | 19 -------------------
 .../ramips/mt76x8/profiles/00-default.mk      | 17 -----------------
 .../ramips/rt305x/profiles/00-default.mk      | 19 -------------------
 .../ramips/rt3883/profiles/00-default.mk      | 17 -----------------
 5 files changed, 89 deletions(-)
 delete mode 100644 target/linux/ramips/mt7620/profiles/00-default.mk
 delete mode 100644 target/linux/ramips/mt7621/profiles/00-default.mk
 delete mode 100644 target/linux/ramips/mt76x8/profiles/00-default.mk
 delete mode 100644 target/linux/ramips/rt305x/profiles/00-default.mk
 delete mode 100644 target/linux/ramips/rt3883/profiles/00-default.mk
diff mbox series

Patch

diff --git a/target/linux/ramips/mt7620/profiles/00-default.mk b/target/linux/ramips/mt7620/profiles/00-default.mk
deleted file mode 100644
index 736a628195..0000000000
--- a/target/linux/ramips/mt7620/profiles/00-default.mk
+++ /dev/null
@@ -1,17 +0,0 @@ 
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PACKAGES:= kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
-	PRIORITY:=1
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/mt7621/profiles/00-default.mk b/target/linux/ramips/mt7621/profiles/00-default.mk
deleted file mode 100644
index dbfd26ed79..0000000000
--- a/target/linux/ramips/mt7621/profiles/00-default.mk
+++ /dev/null
@@ -1,19 +0,0 @@ 
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PRIORITY:=1
-	PACKAGES:=\
-		kmod-usb3 \
-		kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/mt76x8/profiles/00-default.mk b/target/linux/ramips/mt76x8/profiles/00-default.mk
deleted file mode 100644
index 83886eee53..0000000000
--- a/target/linux/ramips/mt76x8/profiles/00-default.mk
+++ /dev/null
@@ -1,17 +0,0 @@ 
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PRIORITY:=1
-	PACKAGES:= kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/rt305x/profiles/00-default.mk b/target/linux/ramips/rt305x/profiles/00-default.mk
deleted file mode 100644
index cc777a8fe4..0000000000
--- a/target/linux/ramips/rt305x/profiles/00-default.mk
+++ /dev/null
@@ -1,19 +0,0 @@ 
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PRIORITY:=1
-	PACKAGES:=\
-		kmod-usb-dwc2 \
-		kmod-usb-ledtrig-usbport
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/rt3883/profiles/00-default.mk b/target/linux/ramips/rt3883/profiles/00-default.mk
deleted file mode 100644
index 468344198c..0000000000
--- a/target/linux/ramips/rt3883/profiles/00-default.mk
+++ /dev/null
@@ -1,17 +0,0 @@ 
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PRIORITY:=1
-	PACKAGES:=kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))