diff mbox series

[RFC] ath79: remove generic profiles

Message ID 20210121194239.13663-1-freifunk@adrianschmutzler.de
State Superseded
Delegated to: Adrian Schmutzler
Headers show
Series [RFC] ath79: remove generic profiles | expand

Commit Message

Adrian Schmutzler Jan. 21, 2021, 7:42 p.m. UTC
On a platform with many very different devices, like found on ath79,
the generic profiles seem like remnants of the past that do not
have a real use anymore.

Remove them to have one thing less to maintain.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

This might also apply to other similar targets like ramips if it
will receive positive feedback.

---
 .../linux/ath79/generic/profiles/00-default.mk | 16 ----------------
 .../ath79/mikrotik/profiles/00-default.mk      | 18 ------------------
 target/linux/ath79/nand/profiles/00-default.mk | 18 ------------------
 target/linux/ath79/tiny/profiles/00-default.mk |  9 ---------
 4 files changed, 61 deletions(-)
 delete mode 100644 target/linux/ath79/generic/profiles/00-default.mk
 delete mode 100644 target/linux/ath79/mikrotik/profiles/00-default.mk
 delete mode 100644 target/linux/ath79/nand/profiles/00-default.mk
 delete mode 100644 target/linux/ath79/tiny/profiles/00-default.mk

Comments

Paul Spooren Jan. 22, 2021, 1:43 a.m. UTC | #1
On Thu Jan 21, 2021 at 9:42 AM HST, Adrian Schmutzler wrote:
> On a platform with many very different devices, like found on ath79,
> the generic profiles seem like remnants of the past that do not
> have a real use anymore.
>
> Remove them to have one thing less to maintain.
>
> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
> ---

Looks good to me. A quick check of target-metadata.pl reveals that the
buildbot enables all profiles per default, so a shortcut via the generic
"profile" isn't required on that end.

From my view, please proceed with other targets.

Acked-by: Paul Spooren <mail@aparcar.org>

>
> This might also apply to other similar targets like ramips if it
> will receive positive feedback.
>
> ---
> .../linux/ath79/generic/profiles/00-default.mk | 16 ----------------
> .../ath79/mikrotik/profiles/00-default.mk | 18 ------------------
> target/linux/ath79/nand/profiles/00-default.mk | 18 ------------------
> target/linux/ath79/tiny/profiles/00-default.mk | 9 ---------
> 4 files changed, 61 deletions(-)
> delete mode 100644 target/linux/ath79/generic/profiles/00-default.mk
> delete mode 100644 target/linux/ath79/mikrotik/profiles/00-default.mk
> delete mode 100644 target/linux/ath79/nand/profiles/00-default.mk
> delete mode 100644 target/linux/ath79/tiny/profiles/00-default.mk
>
> diff --git a/target/linux/ath79/generic/profiles/00-default.mk
> b/target/linux/ath79/generic/profiles/00-default.mk
> deleted file mode 100644
> index 83b39e4418..0000000000
> --- a/target/linux/ath79/generic/profiles/00-default.mk
> +++ /dev/null
> @@ -1,16 +0,0 @@
> -#
> -# Copyright (C) 2009 OpenWrt.org
> -#
> -# This is free software, licensed under the GNU General Public License
> v2.
> -# See /LICENSE for more information.
> -#
> -
> -define Profile/Default
> - NAME:=Default Profile (all drivers)
> - PRIORITY := 1
> -endef
> -
> -define Profile/Default/Description
> - Default package set compatible with most boards.
> -endef
> -$(eval $(call Profile,Default))
> diff --git a/target/linux/ath79/mikrotik/profiles/00-default.mk
> b/target/linux/ath79/mikrotik/profiles/00-default.mk
> deleted file mode 100644
> index 14712da593..0000000000
> --- a/target/linux/ath79/mikrotik/profiles/00-default.mk
> +++ /dev/null
> @@ -1,18 +0,0 @@
> -#
> -# Copyright (C) 2020 OpenWrt.org
> -#
> -# This is free software, licensed under the GNU General Public License
> v2.
> -# See /LICENSE for more information.
> -#
> -
> -define Profile/Default
> - NAME:=Default Profile (all drivers)
> - PACKAGES:= \
> - kmod-usb-ohci kmod-usb2 nand-utils
> - PRIORITY := 1
> -endef
> -
> -define Profile/Default/Description
> - Default package set compatible with most boards.
> -endef
> -$(eval $(call Profile,Default))
> diff --git a/target/linux/ath79/nand/profiles/00-default.mk
> b/target/linux/ath79/nand/profiles/00-default.mk
> deleted file mode 100644
> index 6e618113a5..0000000000
> --- a/target/linux/ath79/nand/profiles/00-default.mk
> +++ /dev/null
> @@ -1,18 +0,0 @@
> -#
> -# Copyright (C) 2009 OpenWrt.org
> -#
> -# This is free software, licensed under the GNU General Public License
> v2.
> -# See /LICENSE for more information.
> -#
> -
> -define Profile/Default
> - NAME:=Default Profile
> - PACKAGES:= \
> - kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
> - PRIORITY := 1
> -endef
> -
> -define Profile/Default/Description
> - Default package set compatible with most boards.
> -endef
> -$(eval $(call Profile,Default))
> diff --git a/target/linux/ath79/tiny/profiles/00-default.mk
> b/target/linux/ath79/tiny/profiles/00-default.mk
> deleted file mode 100644
> index aa8e1195f8..0000000000
> --- a/target/linux/ath79/tiny/profiles/00-default.mk
> +++ /dev/null
> @@ -1,9 +0,0 @@
> -define Profile/Default
> - NAME:=Default Profile (all drivers)
> - PRIORITY := 1
> -endef
> -
> -define Profile/Default/Description
> - Default package set compatible with most boards.
> -endef
> -$(eval $(call Profile,Default))
> --
> 2.20.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/ath79/generic/profiles/00-default.mk b/target/linux/ath79/generic/profiles/00-default.mk
deleted file mode 100644
index 83b39e4418..0000000000
--- a/target/linux/ath79/generic/profiles/00-default.mk
+++ /dev/null
@@ -1,16 +0,0 @@ 
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile (all drivers)
-	PRIORITY := 1
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/mikrotik/profiles/00-default.mk b/target/linux/ath79/mikrotik/profiles/00-default.mk
deleted file mode 100644
index 14712da593..0000000000
--- a/target/linux/ath79/mikrotik/profiles/00-default.mk
+++ /dev/null
@@ -1,18 +0,0 @@ 
-#
-# Copyright (C) 2020 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile (all drivers)
-	PACKAGES:= \
-		kmod-usb-ohci kmod-usb2 nand-utils
-	PRIORITY := 1
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/nand/profiles/00-default.mk b/target/linux/ath79/nand/profiles/00-default.mk
deleted file mode 100644
index 6e618113a5..0000000000
--- a/target/linux/ath79/nand/profiles/00-default.mk
+++ /dev/null
@@ -1,18 +0,0 @@ 
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile
-	PACKAGES:= \
-		kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
-	PRIORITY := 1
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/tiny/profiles/00-default.mk b/target/linux/ath79/tiny/profiles/00-default.mk
deleted file mode 100644
index aa8e1195f8..0000000000
--- a/target/linux/ath79/tiny/profiles/00-default.mk
+++ /dev/null
@@ -1,9 +0,0 @@ 
-define Profile/Default
-	NAME:=Default Profile (all drivers)
-	PRIORITY := 1
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))