diff mbox series

pcre: disable C++ bindings

Message ID 20210121053803.2227179-1-rosenp@gmail.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series pcre: disable C++ bindings | expand

Commit Message

Rosen Penev Jan. 21, 2021, 5:38 a.m. UTC
Nothing uses them. Allows to simplify the Makefile.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/libs/pcre/Makefile | 21 +++------------------
 1 file changed, 3 insertions(+), 18 deletions(-)

Comments

Jan Kardell March 14, 2021, 2:40 p.m. UTC | #1
Rosen Penev skrev:
> Nothing uses them. Allows to simplify the Makefile.
Actually I use it for stuff that is not in openwrt repos. That means I 
must keep pcrecpp out-of-tree. Maybe others do too, but have not yet 
discovered this change. Is really a few saved lines in a makefile worth 
to make life more difficult for people who uses openwrt as a base for 
there own projects? Or is openwrt not meant to be used that way?

So I kindly request that this change is reverted.

//Jan

>
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
>   package/libs/pcre/Makefile | 21 +++------------------
>   1 file changed, 3 insertions(+), 18 deletions(-)
>
> diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
> index 37d939da7f..8644746b4b 100644
> --- a/package/libs/pcre/Makefile
> +++ b/package/libs/pcre/Makefile
> @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
>   
>   PKG_NAME:=pcre
>   PKG_VERSION:=8.44
> -PKG_RELEASE:=3
> +PKG_RELEASE:=4
>   
>   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
>   PKG_SOURCE_URL:=@SF/$(PKG_NAME)
> @@ -24,10 +24,8 @@ PKG_INSTALL:=1
>   PKG_BUILD_PARALLEL:=1
>   
>   PKG_CONFIG_DEPENDS:=\
> -	CONFIG_PACKAGE_libpcrecpp \
>   	CONFIG_PCRE_JIT_ENABLED
>   
> -include $(INCLUDE_DIR)/uclibc++.mk
>   include $(INCLUDE_DIR)/package.mk
>   include $(INCLUDE_DIR)/host-build.mk
>   
> @@ -56,19 +54,12 @@ define Package/libpcre32
>     TITLE:=A Perl Compatible Regular Expression library (32bit support)
>   endef
>   
> -define Package/libpcrecpp
> -  $(call Package/libpcre/default)
> -  TITLE:=C++ wrapper for Perl Compatible Regular Expression library
> -  DEPENDS:=+libpcre $(CXX_DEPENDS)
> -endef
> -
> -
>   HOST_CONFIGURE_ARGS += \
>   	--enable-utf8 \
>   	--enable-unicode-properties \
>   	--enable-pcre16 \
>   	--with-match-limit-recursion=16000 \
> -	--enable-cpp
> +	--disable-cpp
>   
>   TARGET_CFLAGS += $(FPIC)
>   
> @@ -79,7 +70,7 @@ CONFIGURE_ARGS += \
>   	--enable-pcre32 \
>   	$(if $(CONFIG_PCRE_JIT_ENABLED),--enable-jit,--disable-jit) \
>   	--with-match-limit-recursion=16000 \
> -	$(if $(CONFIG_PACKAGE_libpcrecpp),--enable,--disable)-cpp
> +	-disable-cpp
>   
>   MAKE_FLAGS += \
>   	CFLAGS="$(TARGET_CFLAGS)"
> @@ -118,13 +109,7 @@ define Package/libpcre32/install
>   	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre32.so* $(1)/usr/lib/
>   endef
>   
> -define Package/libpcrecpp/install
> -	$(INSTALL_DIR) $(1)/usr/lib
> -	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcrecpp.so.* $(1)/usr/lib/
> -endef
> -
>   $(eval $(call BuildPackage,libpcre))
>   $(eval $(call BuildPackage,libpcre16))
>   $(eval $(call BuildPackage,libpcre32))
> -$(eval $(call BuildPackage,libpcrecpp))
>   $(eval $(call HostBuild))
Rosen Penev March 14, 2021, 9:31 p.m. UTC | #2
On Sun, Mar 14, 2021 at 7:40 AM Jan Kardell <jan.kardell@telliq.com> wrote:
>
> Rosen Penev skrev:
> > Nothing uses them. Allows to simplify the Makefile.
> Actually I use it for stuff that is not in openwrt repos. That means I
> must keep pcrecpp out-of-tree. Maybe others do too, but have not yet
> discovered this change. Is really a few saved lines in a makefile worth
> to make life more difficult for people who uses openwrt as a base for
> there own projects? Or is openwrt not meant to be used that way?
>
> So I kindly request that this change is reverted.
News to me. From the small research I did on Arch and Debian, all
packages use the C API.
>
> //Jan
>
> >
> > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > ---
> >   package/libs/pcre/Makefile | 21 +++------------------
> >   1 file changed, 3 insertions(+), 18 deletions(-)
> >
> > diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
> > index 37d939da7f..8644746b4b 100644
> > --- a/package/libs/pcre/Makefile
> > +++ b/package/libs/pcre/Makefile
> > @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
> >
> >   PKG_NAME:=pcre
> >   PKG_VERSION:=8.44
> > -PKG_RELEASE:=3
> > +PKG_RELEASE:=4
> >
> >   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
> >   PKG_SOURCE_URL:=@SF/$(PKG_NAME)
> > @@ -24,10 +24,8 @@ PKG_INSTALL:=1
> >   PKG_BUILD_PARALLEL:=1
> >
> >   PKG_CONFIG_DEPENDS:=\
> > -     CONFIG_PACKAGE_libpcrecpp \
> >       CONFIG_PCRE_JIT_ENABLED
> >
> > -include $(INCLUDE_DIR)/uclibc++.mk
> >   include $(INCLUDE_DIR)/package.mk
> >   include $(INCLUDE_DIR)/host-build.mk
> >
> > @@ -56,19 +54,12 @@ define Package/libpcre32
> >     TITLE:=A Perl Compatible Regular Expression library (32bit support)
> >   endef
> >
> > -define Package/libpcrecpp
> > -  $(call Package/libpcre/default)
> > -  TITLE:=C++ wrapper for Perl Compatible Regular Expression library
> > -  DEPENDS:=+libpcre $(CXX_DEPENDS)
> > -endef
> > -
> > -
> >   HOST_CONFIGURE_ARGS += \
> >       --enable-utf8 \
> >       --enable-unicode-properties \
> >       --enable-pcre16 \
> >       --with-match-limit-recursion=16000 \
> > -     --enable-cpp
> > +     --disable-cpp
> >
> >   TARGET_CFLAGS += $(FPIC)
> >
> > @@ -79,7 +70,7 @@ CONFIGURE_ARGS += \
> >       --enable-pcre32 \
> >       $(if $(CONFIG_PCRE_JIT_ENABLED),--enable-jit,--disable-jit) \
> >       --with-match-limit-recursion=16000 \
> > -     $(if $(CONFIG_PACKAGE_libpcrecpp),--enable,--disable)-cpp
> > +     -disable-cpp
> >
> >   MAKE_FLAGS += \
> >       CFLAGS="$(TARGET_CFLAGS)"
> > @@ -118,13 +109,7 @@ define Package/libpcre32/install
> >       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre32.so* $(1)/usr/lib/
> >   endef
> >
> > -define Package/libpcrecpp/install
> > -     $(INSTALL_DIR) $(1)/usr/lib
> > -     $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcrecpp.so.* $(1)/usr/lib/
> > -endef
> > -
> >   $(eval $(call BuildPackage,libpcre))
> >   $(eval $(call BuildPackage,libpcre16))
> >   $(eval $(call BuildPackage,libpcre32))
> > -$(eval $(call BuildPackage,libpcrecpp))
> >   $(eval $(call HostBuild))
>
Karl Palsson March 14, 2021, 9:38 p.m. UTC | #3
Rosen Penev <rosenp@gmail.com> wrote:
> On Sun, Mar 14, 2021 at 7:40 AM Jan Kardell
> <jan.kardell@telliq.com> wrote:
> >
> > Rosen Penev skrev:
> > > Nothing uses them. Allows to simplify the Makefile.
> > Actually I use it for stuff that is not in openwrt repos. That means I
> > must keep pcrecpp out-of-tree. Maybe others do too, but have not yet
> > discovered this change. Is really a few saved lines in a makefile worth
> > to make life more difficult for people who uses openwrt as a base for
> > there own projects? Or is openwrt not meant to be used that way?
> >
> > So I kindly request that this change is reverted.
> News to me. From the small research I did on Arch and Debian,
> all packages use the C API.

I would presume they were refering to their own packages not in
the openwrt repos, not "random package frrom arch/debian"

Given how much support _is_ given to downstream openwrt builds,
it doesn't seem unreasonable that for a general package like this
we should offer all of it?

Sincerely,
Karl Palsson
Rosen Penev March 16, 2021, 3:33 a.m. UTC | #4
On Sun, Mar 14, 2021 at 2:40 PM Karl Palsson <karlp@tweak.net.au> wrote:
>
>
> Rosen Penev <rosenp@gmail.com> wrote:
> > On Sun, Mar 14, 2021 at 7:40 AM Jan Kardell
> > <jan.kardell@telliq.com> wrote:
> > >
> > > Rosen Penev skrev:
> > > > Nothing uses them. Allows to simplify the Makefile.
> > > Actually I use it for stuff that is not in openwrt repos. That means I
> > > must keep pcrecpp out-of-tree. Maybe others do too, but have not yet
> > > discovered this change. Is really a few saved lines in a makefile worth
> > > to make life more difficult for people who uses openwrt as a base for
> > > there own projects? Or is openwrt not meant to be used that way?
> > >
> > > So I kindly request that this change is reverted.
> > News to me. From the small research I did on Arch and Debian,
> > all packages use the C API.
>
> I would presume they were refering to their own packages not in
> the openwrt repos, not "random package frrom arch/debian"
>
> Given how much support _is_ given to downstream openwrt builds,
> it doesn't seem unreasonable that for a general package like this
> we should offer all of it?
GMail put this in spam for some reason.

I have no problem with reverting the commit. The uClibc++ stuff should
be removed though.
>
> Sincerely,
> Karl Palsson
Jan Kardell March 16, 2021, 3:54 p.m. UTC | #5
Rosen Penev skrev:
> On Sun, Mar 14, 2021 at 2:40 PM Karl Palsson <karlp@tweak.net.au> wrote:
>>
>> Rosen Penev <rosenp@gmail.com> wrote:
>>> On Sun, Mar 14, 2021 at 7:40 AM Jan Kardell
>>> <jan.kardell@telliq.com> wrote:
>>>> Rosen Penev skrev:
>>>>> Nothing uses them. Allows to simplify the Makefile.
>>>> Actually I use it for stuff that is not in openwrt repos. That means I
>>>> must keep pcrecpp out-of-tree. Maybe others do too, but have not yet
>>>> discovered this change. Is really a few saved lines in a makefile worth
>>>> to make life more difficult for people who uses openwrt as a base for
>>>> there own projects? Or is openwrt not meant to be used that way?
>>>>
>>>> So I kindly request that this change is reverted.
>>> News to me. From the small research I did on Arch and Debian,
>>> all packages use the C API.
>> I would presume they were refering to their own packages not in
>> the openwrt repos, not "random package frrom arch/debian"
Exactly so.

I guess others like me usually builds there stuff on a stable openwrt 
version, and will not discover the removal until they update the codebase.

>>
>> Given how much support _is_ given to downstream openwrt builds,
>> it doesn't seem unreasonable that for a general package like this
>> we should offer all of it?
> GMail put this in spam for some reason.
>
> I have no problem with reverting the commit. The uClibc++ stuff should
> be removed though.

I'm fine with the removal of uClibc++.

//Jan

>> Sincerely,
>> Karl Palsson
diff mbox series

Patch

diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index 37d939da7f..8644746b4b 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -9,7 +9,7 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcre
 PKG_VERSION:=8.44
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -24,10 +24,8 @@  PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
 PKG_CONFIG_DEPENDS:=\
-	CONFIG_PACKAGE_libpcrecpp \
 	CONFIG_PCRE_JIT_ENABLED
 
-include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -56,19 +54,12 @@  define Package/libpcre32
   TITLE:=A Perl Compatible Regular Expression library (32bit support)
 endef
 
-define Package/libpcrecpp
-  $(call Package/libpcre/default)
-  TITLE:=C++ wrapper for Perl Compatible Regular Expression library
-  DEPENDS:=+libpcre $(CXX_DEPENDS)
-endef
-
-
 HOST_CONFIGURE_ARGS += \
 	--enable-utf8 \
 	--enable-unicode-properties \
 	--enable-pcre16 \
 	--with-match-limit-recursion=16000 \
-	--enable-cpp
+	--disable-cpp
 
 TARGET_CFLAGS += $(FPIC)
 
@@ -79,7 +70,7 @@  CONFIGURE_ARGS += \
 	--enable-pcre32 \
 	$(if $(CONFIG_PCRE_JIT_ENABLED),--enable-jit,--disable-jit) \
 	--with-match-limit-recursion=16000 \
-	$(if $(CONFIG_PACKAGE_libpcrecpp),--enable,--disable)-cpp
+	-disable-cpp
 
 MAKE_FLAGS += \
 	CFLAGS="$(TARGET_CFLAGS)"
@@ -118,13 +109,7 @@  define Package/libpcre32/install
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre32.so* $(1)/usr/lib/
 endef
 
-define Package/libpcrecpp/install
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcrecpp.so.* $(1)/usr/lib/
-endef
-
 $(eval $(call BuildPackage,libpcre))
 $(eval $(call BuildPackage,libpcre16))
 $(eval $(call BuildPackage,libpcre32))
-$(eval $(call BuildPackage,libpcrecpp))
 $(eval $(call HostBuild))