diff mbox series

[PATCHv3,1/2] tools/zstd: update to 1.4.8

Message ID 20210121045458.2210790-1-rosenp@gmail.com
State Accepted
Delegated to: Paul Spooren
Headers show
Series [PATCHv3,1/2] tools/zstd: update to 1.4.8 | expand

Commit Message

Rosen Penev Jan. 21, 2021, 4:54 a.m. UTC
Switch to the normal tarball instead of the codeload generated one. The
latter has the potential to change hashes based on changes in the repo.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 v3: converted to use CMake
 v2: forgot to remove upstreamed patch
 tools/zstd/Makefile                           |  7 +--
 ...re-portable-header-prefix-usage-1987.patch | 61 -------------------
 2 files changed, 3 insertions(+), 65 deletions(-)
 delete mode 100644 tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch

Comments

Paul Spooren Jan. 31, 2021, 2:03 a.m. UTC | #1
On Wed Jan 20, 2021 at 6:54 PM HST, Rosen Penev wrote:
> Switch to the normal tarball instead of the codeload generated one. The
> latter has the potential to change hashes based on changes in the repo.
>
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---

Currently zstd fails to compile, is this meant s a fix or unrelated?

compress/zstd_compress.c:2129:1: error: conflicting types for 'ZSTD_compressSequences'
 2129 | ZSTD_compressSequences(seqStore_t* seqStorePtr,
      | ^~~~~~~~~~~~~~~~~~~~~~
In file included from ./common/zstd_internal.h:27,
                 from compress/zstd_compress_internal.h:21,
                 from compress/zstd_compress.c:23:
/home/user/src/openwrt/openwrt/staging_dir/host/include/zstd.h:1370:20: note: previous declaration of 'ZSTD_compressSequences' was here
 1370 | ZSTDLIB_API size_t ZSTD_compressSequences(ZSTD_CCtx* const cctx, void* dst, size_t dstSize,
      |                    ^~~~~~~~~~~~~~~~~~~~~~
compress/zstd_compress.c: In function 'ZSTD_copyBlockSequences':
compress/zstd_compress.c:2337:19: error: 'ZSTD_Sequence' has no member named 'matchPos'
 2337 |         outSeqs[i].matchPos = (unsigned int)position;
      |                   ^

> v3: converted to use CMake
> v2: forgot to remove upstreamed patch
> tools/zstd/Makefile | 7 +--
> ...re-portable-header-prefix-usage-1987.patch | 61 -------------------
> 2 files changed, 3 insertions(+), 65 deletions(-)
> delete mode 100644
> tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
>
> diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
> index 4ec910d4ba..1107c0d92c 100644
> --- a/tools/zstd/Makefile
> +++ b/tools/zstd/Makefile
> @@ -1,12 +1,11 @@
> include $(TOPDIR)/rules.mk
>  
> PKG_NAME:=zstd
> -PKG_VERSION:=1.4.4
> +PKG_VERSION:=1.4.8
>  
> PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
> -PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
> -PKG_SOURCE_URL:=https://github.com/facebook/zstd/archive/
> -PKG_HASH:=a364f5162c7d1a455cc915e8e3cf5f4bd8b75d09bc0f53965b0c9ca1383c52c8
> +PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
> +PKG_HASH:=32478297ca1500211008d596276f5367c54198495cf677e9439f4791a4c69f24
>  
> PKG_LICENSE:=BSD-3-Clause
> PKG_LICENSE_FILES:=LICENSE
> diff --git
> a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> b/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> deleted file mode 100644
> index 6d743aa385..0000000000
> ---
> a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> +++ /dev/null
> @@ -1,61 +0,0 @@
> -From 06a57cf57e3c4e887cadcf688e3081154f3f6db4 Mon Sep 17 00:00:00 2001
> -Message-Id:
> <06a57cf57e3c4e887cadcf688e3081154f3f6db4.1589392463.git.mschiffer@universe-factory.net>
> -From: Bimba Shrestha <bimbashrestha@fb.com>
> -Date: Thu, 6 Feb 2020 14:10:51 -0800
> -Subject: [PATCH] [build-issue] More portable header prefix usage (#)
> (#1987)
> -
> -* make 4.3 build issue fix
> -
> -* Changing header name and adding comment
> ----
> - programs/Makefile | 11 +++++++----
> - 1 file changed, 7 insertions(+), 4 deletions(-)
> -
> -diff --git a/programs/Makefile b/programs/Makefile
> -index b75314a83f43..a9ee3cb5311b 100644
> ---- a/programs/Makefile
> -+++ b/programs/Makefile
> -@@ -94,9 +94,12 @@ endif
> -
> - VOID = /dev/null
> -
> -+# Make 4.3 doesn't support '\#' anymore
> (https://lwn.net/Articles/810071/)
> -+NUM_SYMBOL := \#
> -+
> - # thread detection
> - NO_THREAD_MSG := ==> no threads, building without multithreading
> support
> --HAVE_PTHREAD := $(shell printf '\#include <pthread.h>\nint main(void)
> { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o have_pthread$(EXT)
> have_pthread.c -pthread 2> $(VOID) && rm have_pthread$(EXT) && echo 1 ||
> echo 0; rm have_pthread.c)
> -+HAVE_PTHREAD := $(shell printf '$(NUM_SYMBOL)include <pthread.h>\nint
> main(void) { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o
> have_pthread$(EXT) have_pthread.c -pthread 2> $(VOID) && rm
> have_pthread$(EXT) && echo 1 || echo 0; rm have_pthread.c)
> - HAVE_THREAD := $(shell [ "$(HAVE_PTHREAD)" -eq "1" -o -n "$(filter
> Windows%,$(OS))" ] && echo 1 || echo 0)
> - ifeq ($(HAVE_THREAD), 1)
> - THREAD_MSG := ==> building with threading support
> -@@ -108,7 +111,7 @@ endif
> -
> - # zlib detection
> - NO_ZLIB_MSG := ==> no zlib, building zstd without .gz support
> --HAVE_ZLIB := $(shell printf '\#include <zlib.h>\nint main(void) {
> return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o have_zlib$(EXT)
> have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo 1 || echo 0; rm
> have_zlib.c)
> -+HAVE_ZLIB := $(shell printf '$(NUM_SYMBOL)include <zlib.h>\nint
> main(void) { return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o
> have_zlib$(EXT) have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo
> 1 || echo 0; rm have_zlib.c)
> - ifeq ($(HAVE_ZLIB), 1)
> - ZLIB_MSG := ==> building zstd with .gz compression support
> - ZLIBCPP = -DZSTD_GZCOMPRESS -DZSTD_GZDECOMPRESS
> -@@ -119,7 +122,7 @@ endif
> -
> - # lzma detection
> - NO_LZMA_MSG := ==> no liblzma, building zstd without .xz/.lzma support
> --HAVE_LZMA := $(shell printf '\#include <lzma.h>\nint main(void) {
> return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o have_lzma$(EXT)
> have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) && echo 1 || echo 0;
> rm have_lzma.c)
> -+HAVE_LZMA := $(shell printf '$(NUM_SYMBOL)include <lzma.h>\nint
> main(void) { return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o
> have_lzma$(EXT) have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) &&
> echo 1 || echo 0; rm have_lzma.c)
> - ifeq ($(HAVE_LZMA), 1)
> - LZMA_MSG := ==> building zstd with .xz/.lzma compression support
> - LZMACPP = -DZSTD_LZMACOMPRESS -DZSTD_LZMADECOMPRESS
> -@@ -130,7 +133,7 @@ endif
> -
> - # lz4 detection
> - NO_LZ4_MSG := ==> no liblz4, building zstd without .lz4 support
> --HAVE_LZ4 := $(shell printf '\#include <lz4frame.h>\n\#include
> <lz4.h>\nint main(void) { return 0; }' > have_lz4.c && $(CC) $(FLAGS) -o
> have_lz4$(EXT) have_lz4.c -llz4 2> $(VOID) && rm have_lz4$(EXT) && echo
> 1 || echo 0; rm have_lz4.c)
> -+HAVE_LZ4 := $(shell printf '$(NUM_SYMBOL)include
> <lz4frame.h>\n\#include <lz4.h>\nint main(void) { return 0; }' >
> have_lz4.c && $(CC) $(FLAGS) -o have_lz4$(EXT) have_lz4.c -llz4 2>
> $(VOID) && rm have_lz4$(EXT) && echo 1 || echo 0; rm have_lz4.c)
> - ifeq ($(HAVE_LZ4), 1)
> - LZ4_MSG := ==> building zstd with .lz4 compression support
> - LZ4CPP = -DZSTD_LZ4COMPRESS -DZSTD_LZ4DECOMPRESS
> ---
> -2.26.2
> -
> --
> 2.29.2
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Rosen Penev Jan. 31, 2021, 2:23 a.m. UTC | #2
On Sat, Jan 30, 2021 at 6:03 PM Paul Spooren <mail@aparcar.org> wrote:
>
> On Wed Jan 20, 2021 at 6:54 PM HST, Rosen Penev wrote:
> > Switch to the normal tarball instead of the codeload generated one. The
> > latter has the potential to change hashes based on changes in the repo.
> >
> > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > ---
>
> Currently zstd fails to compile, is this meant s a fix or unrelated?
>
> compress/zstd_compress.c:2129:1: error: conflicting types for 'ZSTD_compressSequences'
>  2129 | ZSTD_compressSequences(seqStore_t* seqStorePtr,
>       | ^~~~~~~~~~~~~~~~~~~~~~
> In file included from ./common/zstd_internal.h:27,
>                  from compress/zstd_compress_internal.h:21,
>                  from compress/zstd_compress.c:23:
> /home/user/src/openwrt/openwrt/staging_dir/host/include/zstd.h:1370:20: note: previous declaration of 'ZSTD_compressSequences' was here
>  1370 | ZSTDLIB_API size_t ZSTD_compressSequences(ZSTD_CCtx* const cctx, void* dst, size_t dstSize,
>       |                    ^~~~~~~~~~~~~~~~~~~~~~
> compress/zstd_compress.c: In function 'ZSTD_copyBlockSequences':
> compress/zstd_compress.c:2337:19: error: 'ZSTD_Sequence' has no member named 'matchPos'
>  2337 |         outSeqs[i].matchPos = (unsigned int)position;
>       |                   ^
>

That looks like a dirty staging_dir. Please wipe and try again.

> > v3: converted to use CMake
> > v2: forgot to remove upstreamed patch
> > tools/zstd/Makefile | 7 +--
> > ...re-portable-header-prefix-usage-1987.patch | 61 -------------------
> > 2 files changed, 3 insertions(+), 65 deletions(-)
> > delete mode 100644
> > tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> >
> > diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
> > index 4ec910d4ba..1107c0d92c 100644
> > --- a/tools/zstd/Makefile
> > +++ b/tools/zstd/Makefile
> > @@ -1,12 +1,11 @@
> > include $(TOPDIR)/rules.mk
> >
> > PKG_NAME:=zstd
> > -PKG_VERSION:=1.4.4
> > +PKG_VERSION:=1.4.8
> >
> > PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
> > -PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
> > -PKG_SOURCE_URL:=https://github.com/facebook/zstd/archive/
> > -PKG_HASH:=a364f5162c7d1a455cc915e8e3cf5f4bd8b75d09bc0f53965b0c9ca1383c52c8
> > +PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
> > +PKG_HASH:=32478297ca1500211008d596276f5367c54198495cf677e9439f4791a4c69f24
> >
> > PKG_LICENSE:=BSD-3-Clause
> > PKG_LICENSE_FILES:=LICENSE
> > diff --git
> > a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> > b/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> > deleted file mode 100644
> > index 6d743aa385..0000000000
> > ---
> > a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
> > +++ /dev/null
> > @@ -1,61 +0,0 @@
> > -From 06a57cf57e3c4e887cadcf688e3081154f3f6db4 Mon Sep 17 00:00:00 2001
> > -Message-Id:
> > <06a57cf57e3c4e887cadcf688e3081154f3f6db4.1589392463.git.mschiffer@universe-factory.net>
> > -From: Bimba Shrestha <bimbashrestha@fb.com>
> > -Date: Thu, 6 Feb 2020 14:10:51 -0800
> > -Subject: [PATCH] [build-issue] More portable header prefix usage (#)
> > (#1987)
> > -
> > -* make 4.3 build issue fix
> > -
> > -* Changing header name and adding comment
> > ----
> > - programs/Makefile | 11 +++++++----
> > - 1 file changed, 7 insertions(+), 4 deletions(-)
> > -
> > -diff --git a/programs/Makefile b/programs/Makefile
> > -index b75314a83f43..a9ee3cb5311b 100644
> > ---- a/programs/Makefile
> > -+++ b/programs/Makefile
> > -@@ -94,9 +94,12 @@ endif
> > -
> > - VOID = /dev/null
> > -
> > -+# Make 4.3 doesn't support '\#' anymore
> > (https://lwn.net/Articles/810071/)
> > -+NUM_SYMBOL := \#
> > -+
> > - # thread detection
> > - NO_THREAD_MSG := ==> no threads, building without multithreading
> > support
> > --HAVE_PTHREAD := $(shell printf '\#include <pthread.h>\nint main(void)
> > { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o have_pthread$(EXT)
> > have_pthread.c -pthread 2> $(VOID) && rm have_pthread$(EXT) && echo 1 ||
> > echo 0; rm have_pthread.c)
> > -+HAVE_PTHREAD := $(shell printf '$(NUM_SYMBOL)include <pthread.h>\nint
> > main(void) { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o
> > have_pthread$(EXT) have_pthread.c -pthread 2> $(VOID) && rm
> > have_pthread$(EXT) && echo 1 || echo 0; rm have_pthread.c)
> > - HAVE_THREAD := $(shell [ "$(HAVE_PTHREAD)" -eq "1" -o -n "$(filter
> > Windows%,$(OS))" ] && echo 1 || echo 0)
> > - ifeq ($(HAVE_THREAD), 1)
> > - THREAD_MSG := ==> building with threading support
> > -@@ -108,7 +111,7 @@ endif
> > -
> > - # zlib detection
> > - NO_ZLIB_MSG := ==> no zlib, building zstd without .gz support
> > --HAVE_ZLIB := $(shell printf '\#include <zlib.h>\nint main(void) {
> > return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o have_zlib$(EXT)
> > have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo 1 || echo 0; rm
> > have_zlib.c)
> > -+HAVE_ZLIB := $(shell printf '$(NUM_SYMBOL)include <zlib.h>\nint
> > main(void) { return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o
> > have_zlib$(EXT) have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo
> > 1 || echo 0; rm have_zlib.c)
> > - ifeq ($(HAVE_ZLIB), 1)
> > - ZLIB_MSG := ==> building zstd with .gz compression support
> > - ZLIBCPP = -DZSTD_GZCOMPRESS -DZSTD_GZDECOMPRESS
> > -@@ -119,7 +122,7 @@ endif
> > -
> > - # lzma detection
> > - NO_LZMA_MSG := ==> no liblzma, building zstd without .xz/.lzma support
> > --HAVE_LZMA := $(shell printf '\#include <lzma.h>\nint main(void) {
> > return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o have_lzma$(EXT)
> > have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) && echo 1 || echo 0;
> > rm have_lzma.c)
> > -+HAVE_LZMA := $(shell printf '$(NUM_SYMBOL)include <lzma.h>\nint
> > main(void) { return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o
> > have_lzma$(EXT) have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) &&
> > echo 1 || echo 0; rm have_lzma.c)
> > - ifeq ($(HAVE_LZMA), 1)
> > - LZMA_MSG := ==> building zstd with .xz/.lzma compression support
> > - LZMACPP = -DZSTD_LZMACOMPRESS -DZSTD_LZMADECOMPRESS
> > -@@ -130,7 +133,7 @@ endif
> > -
> > - # lz4 detection
> > - NO_LZ4_MSG := ==> no liblz4, building zstd without .lz4 support
> > --HAVE_LZ4 := $(shell printf '\#include <lz4frame.h>\n\#include
> > <lz4.h>\nint main(void) { return 0; }' > have_lz4.c && $(CC) $(FLAGS) -o
> > have_lz4$(EXT) have_lz4.c -llz4 2> $(VOID) && rm have_lz4$(EXT) && echo
> > 1 || echo 0; rm have_lz4.c)
> > -+HAVE_LZ4 := $(shell printf '$(NUM_SYMBOL)include
> > <lz4frame.h>\n\#include <lz4.h>\nint main(void) { return 0; }' >
> > have_lz4.c && $(CC) $(FLAGS) -o have_lz4$(EXT) have_lz4.c -llz4 2>
> > $(VOID) && rm have_lz4$(EXT) && echo 1 || echo 0; rm have_lz4.c)
> > - ifeq ($(HAVE_LZ4), 1)
> > - LZ4_MSG := ==> building zstd with .lz4 compression support
> > - LZ4CPP = -DZSTD_LZ4COMPRESS -DZSTD_LZ4DECOMPRESS
> > ---
> > -2.26.2
> > -
> > --
> > 2.29.2
> >
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>
diff mbox series

Patch

diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 4ec910d4ba..1107c0d92c 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -1,12 +1,11 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zstd
-PKG_VERSION:=1.4.4
+PKG_VERSION:=1.4.8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/facebook/zstd/archive/
-PKG_HASH:=a364f5162c7d1a455cc915e8e3cf5f4bd8b75d09bc0f53965b0c9ca1383c52c8
+PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
+PKG_HASH:=32478297ca1500211008d596276f5367c54198495cf677e9439f4791a4c69f24
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
diff --git a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch b/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
deleted file mode 100644
index 6d743aa385..0000000000
--- a/tools/zstd/patches/0001-build-issue-More-portable-header-prefix-usage-1987.patch
+++ /dev/null
@@ -1,61 +0,0 @@ 
-From 06a57cf57e3c4e887cadcf688e3081154f3f6db4 Mon Sep 17 00:00:00 2001
-Message-Id: <06a57cf57e3c4e887cadcf688e3081154f3f6db4.1589392463.git.mschiffer@universe-factory.net>
-From: Bimba Shrestha <bimbashrestha@fb.com>
-Date: Thu, 6 Feb 2020 14:10:51 -0800
-Subject: [PATCH] [build-issue] More portable header prefix usage (#) (#1987)
-
-* make 4.3 build issue fix
-
-* Changing header name and adding comment
----
- programs/Makefile | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/programs/Makefile b/programs/Makefile
-index b75314a83f43..a9ee3cb5311b 100644
---- a/programs/Makefile
-+++ b/programs/Makefile
-@@ -94,9 +94,12 @@ endif
- 
- VOID = /dev/null
- 
-+# Make 4.3 doesn't support '\#' anymore (https://lwn.net/Articles/810071/)
-+NUM_SYMBOL := \#
-+
- # thread detection
- NO_THREAD_MSG := ==> no threads, building without multithreading support
--HAVE_PTHREAD := $(shell printf '\#include <pthread.h>\nint main(void) { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o have_pthread$(EXT) have_pthread.c -pthread 2> $(VOID) && rm have_pthread$(EXT) && echo 1 || echo 0; rm have_pthread.c)
-+HAVE_PTHREAD := $(shell printf '$(NUM_SYMBOL)include <pthread.h>\nint main(void) { return 0; }' > have_pthread.c && $(CC) $(FLAGS) -o have_pthread$(EXT) have_pthread.c -pthread 2> $(VOID) && rm have_pthread$(EXT) && echo 1 || echo 0; rm have_pthread.c)
- HAVE_THREAD := $(shell [ "$(HAVE_PTHREAD)" -eq "1" -o -n "$(filter Windows%,$(OS))" ] && echo 1 || echo 0)
- ifeq ($(HAVE_THREAD), 1)
- THREAD_MSG := ==> building with threading support
-@@ -108,7 +111,7 @@ endif
- 
- # zlib detection
- NO_ZLIB_MSG := ==> no zlib, building zstd without .gz support
--HAVE_ZLIB := $(shell printf '\#include <zlib.h>\nint main(void) { return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o have_zlib$(EXT) have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo 1 || echo 0; rm have_zlib.c)
-+HAVE_ZLIB := $(shell printf '$(NUM_SYMBOL)include <zlib.h>\nint main(void) { return 0; }' > have_zlib.c && $(CC) $(FLAGS) -o have_zlib$(EXT) have_zlib.c -lz 2> $(VOID) && rm have_zlib$(EXT) && echo 1 || echo 0; rm have_zlib.c)
- ifeq ($(HAVE_ZLIB), 1)
- ZLIB_MSG := ==> building zstd with .gz compression support
- ZLIBCPP = -DZSTD_GZCOMPRESS -DZSTD_GZDECOMPRESS
-@@ -119,7 +122,7 @@ endif
- 
- # lzma detection
- NO_LZMA_MSG := ==> no liblzma, building zstd without .xz/.lzma support
--HAVE_LZMA := $(shell printf '\#include <lzma.h>\nint main(void) { return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o have_lzma$(EXT) have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) && echo 1 || echo 0; rm have_lzma.c)
-+HAVE_LZMA := $(shell printf '$(NUM_SYMBOL)include <lzma.h>\nint main(void) { return 0; }' > have_lzma.c && $(CC) $(FLAGS) -o have_lzma$(EXT) have_lzma.c -llzma 2> $(VOID) && rm have_lzma$(EXT) && echo 1 || echo 0; rm have_lzma.c)
- ifeq ($(HAVE_LZMA), 1)
- LZMA_MSG := ==> building zstd with .xz/.lzma compression support
- LZMACPP = -DZSTD_LZMACOMPRESS -DZSTD_LZMADECOMPRESS
-@@ -130,7 +133,7 @@ endif
- 
- # lz4 detection
- NO_LZ4_MSG := ==> no liblz4, building zstd without .lz4 support
--HAVE_LZ4 := $(shell printf '\#include <lz4frame.h>\n\#include <lz4.h>\nint main(void) { return 0; }' > have_lz4.c && $(CC) $(FLAGS) -o have_lz4$(EXT) have_lz4.c -llz4 2> $(VOID) && rm have_lz4$(EXT) && echo 1 || echo 0; rm have_lz4.c)
-+HAVE_LZ4 := $(shell printf '$(NUM_SYMBOL)include <lz4frame.h>\n\#include <lz4.h>\nint main(void) { return 0; }' > have_lz4.c && $(CC) $(FLAGS) -o have_lz4$(EXT) have_lz4.c -llz4 2> $(VOID) && rm have_lz4$(EXT) && echo 1 || echo 0; rm have_lz4.c)
- ifeq ($(HAVE_LZ4), 1)
- LZ4_MSG := ==> building zstd with .lz4 compression support
- LZ4CPP = -DZSTD_LZ4COMPRESS -DZSTD_LZ4DECOMPRESS
--- 
-2.26.2
-