diff mbox series

util-linux: fix bad pkgconf variable

Message ID 20210120001607.355472-1-rosenp@gmail.com
State Superseded
Headers show
Series util-linux: fix bad pkgconf variable | expand

Commit Message

Rosen Penev Jan. 20, 2021, 12:16 a.m. UTC
Because of the lib prefix, it's not getting substituted properly and
breaks compilation of other packages.

Fixes error with at least btrfs-progs:

Package '@LIBSELINUX@', required by 'mount', not found
Package '@LIBCRYPTSETUP@', required by 'mount', not foun

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/utils/util-linux/Makefile                     |  2 +-
 .../util-linux/patches/010-mount-pkgconfig.patch      | 11 +++++++++++
 2 files changed, 12 insertions(+), 1 deletion(-)
 create mode 100644 package/utils/util-linux/patches/010-mount-pkgconfig.patch

Comments

Hauke Mehrtens Jan. 27, 2021, 11:11 p.m. UTC | #1
On 1/20/21 1:16 AM, Rosen Penev wrote:
> Because of the lib prefix, it's not getting substituted properly and
> breaks compilation of other packages.
> 
> Fixes error with at least btrfs-progs:
> 
> Package '@LIBSELINUX@', required by 'mount', not found
> Package '@LIBCRYPTSETUP@', required by 'mount', not foun
> 
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
>   package/utils/util-linux/Makefile                     |  2 +-
>   .../util-linux/patches/010-mount-pkgconfig.patch      | 11 +++++++++++
>   2 files changed, 12 insertions(+), 1 deletion(-)
>   create mode 100644 package/utils/util-linux/patches/010-mount-pkgconfig.patch
> 
> diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
> index 31a66493e9..7551fe867b 100644
> --- a/package/utils/util-linux/Makefile
> +++ b/package/utils/util-linux/Makefile
> @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
>   
>   PKG_NAME:=util-linux
>   PKG_VERSION:=2.36.1
> -PKG_RELEASE:=1
> +PKG_RELEASE:=2
>   
>   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
>   PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
> diff --git a/package/utils/util-linux/patches/010-mount-pkgconfig.patch b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
> new file mode 100644
> index 0000000000..a0f9bf3a3c
> --- /dev/null
> +++ b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
> @@ -0,0 +1,11 @@
> +--- a/libmount/mount.pc.in
> ++++ b/libmount/mount.pc.in
> +@@ -17,7 +17,7 @@ includedir=@includedir@
> + Name: mount
> + Description: mount library
> + Version: @LIBMOUNT_VERSION@
> +-Requires.private: blkid @LIBSELINUX@ @LIBCRYPTSETUP@
> ++Requires.private: blkid @SELINUX_LIBS@ @CRYPTSETUP_LIBS@
> + Cflags: -I${includedir}/libmount
> + Libs: -L${libdir} -lmount
> + Libs.private: @LIBDL@
> 
Hi,

This problem was introduced in OpenWrt in this patch:
https://git.openwrt.org/ba887275ca56c28e6b7a6aecda26e7fd4107f4bc

The @LIBSELINUX@ and @LIBCRYPTSETUP@ expansions are applied to all files 
in the PATHFILES variable, see here:
https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git/tree/Makefile.am?h=v2.36.1#n175

All Makefile.in files are automatically in there and some are manually 
added with PATHFILES. The mentioned patch in OpenWrt removes these files 
from the PATHFILES variable.

We should try to fix or get rid of this OpenWrt patch.

Hauke
Rosen Penev Jan. 28, 2021, 5:05 a.m. UTC | #2
On Wed, Jan 27, 2021 at 3:11 PM Hauke Mehrtens <hauke@hauke-m.de> wrote:
>
> On 1/20/21 1:16 AM, Rosen Penev wrote:
> > Because of the lib prefix, it's not getting substituted properly and
> > breaks compilation of other packages.
> >
> > Fixes error with at least btrfs-progs:
> >
> > Package '@LIBSELINUX@', required by 'mount', not found
> > Package '@LIBCRYPTSETUP@', required by 'mount', not foun
> >
> > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > ---
> >   package/utils/util-linux/Makefile                     |  2 +-
> >   .../util-linux/patches/010-mount-pkgconfig.patch      | 11 +++++++++++
> >   2 files changed, 12 insertions(+), 1 deletion(-)
> >   create mode 100644 package/utils/util-linux/patches/010-mount-pkgconfig.patch
> >
> > diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
> > index 31a66493e9..7551fe867b 100644
> > --- a/package/utils/util-linux/Makefile
> > +++ b/package/utils/util-linux/Makefile
> > @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
> >
> >   PKG_NAME:=util-linux
> >   PKG_VERSION:=2.36.1
> > -PKG_RELEASE:=1
> > +PKG_RELEASE:=2
> >
> >   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
> >   PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
> > diff --git a/package/utils/util-linux/patches/010-mount-pkgconfig.patch b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
> > new file mode 100644
> > index 0000000000..a0f9bf3a3c
> > --- /dev/null
> > +++ b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
> > @@ -0,0 +1,11 @@
> > +--- a/libmount/mount.pc.in
> > ++++ b/libmount/mount.pc.in
> > +@@ -17,7 +17,7 @@ includedir=@includedir@
> > + Name: mount
> > + Description: mount library
> > + Version: @LIBMOUNT_VERSION@
> > +-Requires.private: blkid @LIBSELINUX@ @LIBCRYPTSETUP@
> > ++Requires.private: blkid @SELINUX_LIBS@ @CRYPTSETUP_LIBS@
> > + Cflags: -I${includedir}/libmount
> > + Libs: -L${libdir} -lmount
> > + Libs.private: @LIBDL@
> >
> Hi,
>
> This problem was introduced in OpenWrt in this patch:
> https://git.openwrt.org/ba887275ca56c28e6b7a6aecda26e7fd4107f4bc
>
> The @LIBSELINUX@ and @LIBCRYPTSETUP@ expansions are applied to all files
> in the PATHFILES variable, see here:
> https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git/tree/Makefile.am?h=v2.36.1#n175
>
> All Makefile.in files are automatically in there and some are manually
> added with PATHFILES. The mentioned patch in OpenWrt removes these files
> from the PATHFILES variable.
>
> We should try to fix or get rid of this OpenWrt patch.
Sounds about right. The bad paths mentioned in that commit can just be
dealt with with sed.
>
> Hauke
>
diff mbox series

Patch

diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 31a66493e9..7551fe867b 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -9,7 +9,7 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.36.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
diff --git a/package/utils/util-linux/patches/010-mount-pkgconfig.patch b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
new file mode 100644
index 0000000000..a0f9bf3a3c
--- /dev/null
+++ b/package/utils/util-linux/patches/010-mount-pkgconfig.patch
@@ -0,0 +1,11 @@ 
+--- a/libmount/mount.pc.in
++++ b/libmount/mount.pc.in
+@@ -17,7 +17,7 @@ includedir=@includedir@
+ Name: mount
+ Description: mount library
+ Version: @LIBMOUNT_VERSION@
+-Requires.private: blkid @LIBSELINUX@ @LIBCRYPTSETUP@
++Requires.private: blkid @SELINUX_LIBS@ @CRYPTSETUP_LIBS@
+ Cflags: -I${includedir}/libmount
+ Libs: -L${libdir} -lmount
+ Libs.private: @LIBDL@