diff mbox series

rpcd CMakeLists.txt: install unauthenticated.json

Message ID 20210119072425.19276-1-stokito@gmail.com
State New
Headers show
Series rpcd CMakeLists.txt: install unauthenticated.json | expand

Commit Message

Sergey Ponomarev Jan. 19, 2021, 7:24 a.m. UTC
When installing rpcd directly from CMake then the file is missing.

Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
---
 CMakeLists.txt | 3 +++
 1 file changed, 3 insertions(+)

Comments

Rosen Penev Jan. 19, 2021, 10:41 a.m. UTC | #1
On Mon, Jan 18, 2021 at 11:27 PM Sergey Ponomarev <stokito@gmail.com> wrote:
>
> When installing rpcd directly from CMake then the file is missing.
>
> Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
Reviewed-by: Rosen Penev <rosenp@gmail.com>
> ---
>  CMakeLists.txt | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/CMakeLists.txt b/CMakeLists.txt
> index 266dbe4..213b4ba 100644
> --- a/CMakeLists.txt
> +++ b/CMakeLists.txt
> @@ -69,3 +69,6 @@ INSTALL(TARGETS rpcd ${PLUGINS}
>         RUNTIME DESTINATION sbin
>         LIBRARY DESTINATION lib
>  )
> +INSTALL(FILES unauthenticated.json
> +       DESTINATION share/rpcd/aclh.d
> +)
> --
> 2.27.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 266dbe4..213b4ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,3 +69,6 @@  INSTALL(TARGETS rpcd ${PLUGINS}
 	RUNTIME DESTINATION sbin
 	LIBRARY DESTINATION lib
 )
+INSTALL(FILES unauthenticated.json
+	DESTINATION share/rpcd/aclh.d
+)