diff mbox series

[v2] build/prereq: require make 4.1 or later

Message ID 20201213190319.615018-1-mail@aparcar.org
State Accepted
Delegated to: Paul Spooren
Headers show
Series [v2] build/prereq: require make 4.1 or later | expand

Commit Message

Paul Spooren Dec. 13, 2020, 7:03 p.m. UTC
FS#2086 "IS_TTY in the makefile is broken" reports flawed detection of
stdout piping to a file. The issue describes how e.g. terminal color
codes and up in log files if running make like `make > log.txt`.

The proposed solution uses the make variable "MAKE_TERMOUT", which was
introduced in make 4.1. All major distributions seem to updated to 4.1
or later, so this ideally dosen't break anything.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
Fixed two typos

 include/prereq-build.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 5045fabdfb..ad204e95e8 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -14,8 +14,8 @@  PKG_NAME:=Build dependency
 
 # Required for the toolchain
 $(eval $(call TestHostCommand,working-make, \
-	Please install GNU make v3.82 or later. (This version has bugs), \
-	$(MAKE) -v | grep -E 'Make (3\.8[2-9]|3\.9[0-9]|[4-9]\.)'))
+	Please install GNU make v4.1 or later., \
+	$(MAKE) -v | grep -E 'Make (4\.[1-9]|[5-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
 	OpenWrt can only be built on a case-sensitive filesystem, \