diff mbox series

[19.07,4/6] download.pl: properly cleanup intermediate .hash file

Message ID 20201202103414.18636-5-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [19.07,1/6] cmake.mk: set C/CXX compiler for host builds as well | expand

Commit Message

Petr Štetiar Dec. 2, 2020, 10:34 a.m. UTC
It seems like after a build the /dl dir seems to now contain a .hash
file for each source file due to inproper cleanup so fix it by removing
those intermediate files before leaving the download action.

Fixes: 4e19cbc55335 ("download: handle possibly invalid local tarballs")
Reported-by: Hannu Nyman <hannu.nyman@iki.fi>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 52a5d0d27f2557db99fc5435fbd7783b649cb9b2)
---
 scripts/download.pl | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/scripts/download.pl b/scripts/download.pl
index c1623bf91fe0..2876ae5807cd 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -273,11 +273,11 @@  if (-f "$target/$filename") {
 		$sum =~ /^(\w+)\s*/ or die "Could not generate file hash\n";
 		$sum = $1;
 
+		cleanup();
 		exit 0 if $sum eq $file_hash;
 
 		die "Hash of the local file $filename does not match (file: $sum, requested: $file_hash) - deleting download.\n";
 		unlink "$target/$filename";
-		cleanup();
 	};
 }