diff mbox series

rtl838x: fine tune default package set

Message ID 20201109173245.12551-1-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series rtl838x: fine tune default package set | expand

Commit Message

Petr Štetiar Nov. 9, 2020, 5:32 p.m. UTC
Althought most of the switches aren't routers, they can be used as such,
so let's add some of the packages from the router's DEVICE_TYPE. While
at it, remove swconfig package which is not needed on DSA targets.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 target/linux/rtl838x/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

John Crispin Nov. 9, 2020, 6:55 p.m. UTC | #1
On 09.11.20 18:32, Petr Štetiar wrote:
> Althought most of the switches aren't routers, they can be used as such,
> so let's add some of the packages from the router's DEVICE_TYPE. While
> at it, remove swconfig package which is not needed on DSA targets.
>
> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Acked-by: John Crispin <john@phrozen.org>
> ---
>   target/linux/rtl838x/Makefile | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/target/linux/rtl838x/Makefile b/target/linux/rtl838x/Makefile
> index 83cb074b89b6..a4e203718d90 100644
> --- a/target/linux/rtl838x/Makefile
> +++ b/target/linux/rtl838x/Makefile
> @@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/target.mk
>   
>   FEATURES := $(filter-out mips16,$(FEATURES))
>   
> -DEFAULT_PACKAGES += swconfig uboot-envtools ethtool kmod-gpio-button-hotplug
> +DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
> +	dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
>   
>   $(eval $(call BuildTarget))
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/rtl838x/Makefile b/target/linux/rtl838x/Makefile
index 83cb074b89b6..a4e203718d90 100644
--- a/target/linux/rtl838x/Makefile
+++ b/target/linux/rtl838x/Makefile
@@ -21,6 +21,7 @@  include $(INCLUDE_DIR)/target.mk
 
 FEATURES := $(filter-out mips16,$(FEATURES))
 
-DEFAULT_PACKAGES += swconfig uboot-envtools ethtool kmod-gpio-button-hotplug
+DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
+	dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
 
 $(eval $(call BuildTarget))