diff mbox series

bcm27xx: add bit variant to redundant RaspberryPi

Message ID 20201106200030.3038091-1-mail@aparcar.org
State Superseded
Headers show
Series bcm27xx: add bit variant to redundant RaspberryPi | expand

Commit Message

Paul Spooren Nov. 6, 2020, 8 p.m. UTC
Both bcm2709 and bcm2710 firmware can run on the same RaspberryPi
models, varying however in 32 and 64 Bit architectures. The model name
alone does not include the architecture information, which becomes
problematic if looking at a overview that only contains the names. By
adding a variant it is possible to tell the architecture.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 target/linux/bcm27xx/image/Makefile | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index f009b997e9..6b533cad42 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -87,6 +87,7 @@  endif
 
 define Device/rpi-2
   DEVICE_MODEL := 2B/3B/3B+/3CM/4B
+  DEVICE_VARIANT := (32bit)
   DEVICE_DTS := \
 	bcm2709-rpi-2-b bcm2710-rpi-2-b \
 	bcm2710-rpi-3-b bcm2710-rpi-3-b-plus \
@@ -113,6 +114,7 @@  endif
 
 define Device/rpi-3
   DEVICE_MODEL := 2B-1.2/3B/3B+/3CM
+  DEVICE_VARIANT := (64bit)
   KERNEL_IMG := kernel8.img
   DEVICE_DTS := \
 	broadcom/bcm2710-rpi-2-b \