diff mbox series

[buildbot] phase1: don't add kmod feed via buildbot

Message ID 20201021233946.3723717-1-mail@aparcar.org
State Superseded
Delegated to: Jo-Philipp Wich
Headers show
Series [buildbot] phase1: don't add kmod feed via buildbot | expand

Commit Message

Paul Spooren Oct. 21, 2020, 11:39 p.m. UTC
The kmod feed links to a kernel specific archive of compatible kmods.
This allows snapshot devices install kmods even after the upstream
kernel version changed.

As the kmod feed is usable for both firmware and ImageBuilders, the feed
should be added via openwrt.git/include/feeds.mk instead of *hacked*
into the images by the buildbot.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
Patch for openwrt.git is here:
https://github.com/openwrt/openwrt/pull/3425/commits/9343e7d65494b6b9fd7bf0d76b0d5371f7e6dbd2

 phase1/master.cfg | 27 ---------------------------
 1 file changed, 27 deletions(-)
diff mbox series

Patch

diff --git a/phase1/master.cfg b/phase1/master.cfg
index 3ba7a16..0b3e3eb 100644
--- a/phase1/master.cfg
+++ b/phase1/master.cfg
@@ -1003,33 +1003,6 @@  for target in targets:
 		haltOnFailure = True
 	))
 
-	if enable_kmod_archive:
-		# embed kmod repository. Must happen before 'images'
-
-		# find rootfs staging directory
-		factory.addStep(SetPropertyFromCommand(
-			name = "stageroot",
-			property = "stageroot",
-			description = "Finding the rootfs staging directory",
-			command=["make", "--no-print-directory", "val.STAGING_DIR_ROOT"],
-			env = { 'TOPDIR': Interpolate("%(kw:cwd)s/build", cwd=GetCwd) }
-		))
-
-		factory.addStep(ShellCommand(
-			name = "filesdir",
-			description = "Creating file overlay directory",
-			command=["mkdir", "-p", "files/etc/opkg"],
-			haltOnFailure = True
-		))
-
-		factory.addStep(ShellCommand(
-			name = "kmodconfig",
-			description = "Embedding kmod repository configuration",
-			command=Interpolate("sed -e 's#^\\(src/gz .*\\)_core \\(.*\\)/packages$#&\\n\\1_kmods \\2/kmods/%(prop:kernelversion)s#' " +
-			                       "%(prop:stageroot)s/etc/opkg/distfeeds.conf > files/etc/opkg/distfeeds.conf"),
-			haltOnFailure = True
-		))
-
 	#factory.addStep(IfBuiltinShellCommand(
 	factory.addStep(ShellCommand(
 		name = "images",