diff mbox series

[2/4] kernel: Move CONFIG_F2FS_FS_SECURITY to generic kernel config

Message ID 20201010151224.6330-2-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series [1/4] kernel: Remove 2FS_FS_XATTR and F2FS_STAT_FS symbols from target configs | expand

Commit Message

Hauke Mehrtens Oct. 10, 2020, 3:12 p.m. UTC
Move the CONFIG_F2FS_FS_SECURITY kernel configuration option to the
generic kernel configuration.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 package/kernel/linux/modules/fs.mk        | 1 -
 target/linux/apm821xx/sata/config-default | 1 -
 target/linux/armvirt/config-4.19          | 1 -
 target/linux/armvirt/config-5.4           | 1 -
 target/linux/generic/config-4.19          | 1 +
 target/linux/imx6/config-4.19             | 1 -
 target/linux/malta/config-4.19            | 1 -
 target/linux/mediatek/mt7623/config-4.19  | 1 -
 target/linux/mvebu/config-4.19            | 1 -
 target/linux/octeon/config-4.19           | 1 -
 target/linux/omap/config-4.19             | 1 -
 target/linux/sunxi/config-4.19            | 1 -
 target/linux/tegra/config-4.19            | 1 -
 target/linux/tegra/config-5.4             | 1 -
 target/linux/x86/config-4.19              | 1 -
 target/linux/x86/config-5.4               | 1 -
 target/linux/zynq/config-4.19             | 1 -
 target/linux/zynq/config-5.4              | 1 -
 18 files changed, 1 insertion(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 0abd5285db48..db753308eec0 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -209,7 +209,6 @@  define KernelPackage/fs-f2fs
   KCONFIG:= \
 	CONFIG_F2FS_FS \
 	CONFIG_F2FS_FS_POSIX_ACL=n \
-	CONFIG_F2FS_FS_SECURITY=n \
 	CONFIG_F2FS_CHECK_FS=n
   FILES:=$(LINUX_DIR)/fs/f2fs/f2fs.ko
   AUTOLOAD:=$(call AutoLoad,30,f2fs,1)
diff --git a/target/linux/apm821xx/sata/config-default b/target/linux/apm821xx/sata/config-default
index 15aed962d5d2..284ba04bb8f3 100644
--- a/target/linux/apm821xx/sata/config-default
+++ b/target/linux/apm821xx/sata/config-default
@@ -17,7 +17,6 @@  CONFIG_SATA_DWC=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_SCSI=y
 CONFIG_BLK_DEV_SD=y
 CONFIG_GPIOLIB=y
diff --git a/target/linux/armvirt/config-4.19 b/target/linux/armvirt/config-4.19
index a9a17ecae38a..945cf9189327 100644
--- a/target/linux/armvirt/config-4.19
+++ b/target/linux/armvirt/config-4.19
@@ -57,7 +57,6 @@  CONFIG_EDAC_SUPPORT=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FAILOVER=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FRAME_POINTER=y
diff --git a/target/linux/armvirt/config-5.4 b/target/linux/armvirt/config-5.4
index 30ad3d26eab3..f2c43a3ff2fb 100644
--- a/target/linux/armvirt/config-5.4
+++ b/target/linux/armvirt/config-5.4
@@ -70,7 +70,6 @@  CONFIG_EDAC_SUPPORT=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FAILOVER=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FRAME_POINTER=y
diff --git a/target/linux/generic/config-4.19 b/target/linux/generic/config-4.19
index 6c88e4159321..3de757ae2661 100644
--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -1407,6 +1407,7 @@  CONFIG_EXTRA_TARGETS=""
 # CONFIG_F2FS_FS is not set
 # CONFIG_F2FS_FS_ENCRYPTION is not set
 # CONFIG_F2FS_FS_POSIX_ACL is not set
+# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_F2FS_FS_XATTR=y
 # CONFIG_F2FS_IO_TRACE is not set
 CONFIG_F2FS_STAT_FS=y
diff --git a/target/linux/imx6/config-4.19 b/target/linux/imx6/config-4.19
index 5a3d02968012..d38ebe10e43b 100644
--- a/target/linux/imx6/config-4.19
+++ b/target/linux/imx6/config-4.19
@@ -190,7 +190,6 @@  CONFIG_EXTRA_FIRMWARE="imx/sdma/sdma-imx6q.bin"
 CONFIG_EXTRA_FIRMWARE_DIR="firmware"
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FEC=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
diff --git a/target/linux/malta/config-4.19 b/target/linux/malta/config-4.19
index 1f1b6fb54918..3cb1b34eaecf 100644
--- a/target/linux/malta/config-4.19
+++ b/target/linux/malta/config-4.19
@@ -95,7 +95,6 @@  CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FS_IOMAP=y
 CONFIG_FS_MBCACHE=y
 CONFIG_FS_POSIX_ACL=y
diff --git a/target/linux/mediatek/mt7623/config-4.19 b/target/linux/mediatek/mt7623/config-4.19
index edf285c45a7c..01c96b1f0a86 100644
--- a/target/linux/mediatek/mt7623/config-4.19
+++ b/target/linux/mediatek/mt7623/config-4.19
@@ -175,7 +175,6 @@  CONFIG_ELF_CORE=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FREEZER=y
diff --git a/target/linux/mvebu/config-4.19 b/target/linux/mvebu/config-4.19
index 1eae0a55db4a..5dbbb5956227 100644
--- a/target/linux/mvebu/config-4.19
+++ b/target/linux/mvebu/config-4.19
@@ -178,7 +178,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FS_IOMAP=y
diff --git a/target/linux/octeon/config-4.19 b/target/linux/octeon/config-4.19
index d9a624d3b8ad..49ecd3d43a0d 100644
--- a/target/linux/octeon/config-4.19
+++ b/target/linux/octeon/config-4.19
@@ -75,7 +75,6 @@  CONFIG_ENABLE_MUST_CHECK=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FAT_FS=y
 CONFIG_FIXED_PHY=y
 CONFIG_FRAME_WARN=2048
diff --git a/target/linux/omap/config-4.19 b/target/linux/omap/config-4.19
index ead207fc2dc8..db37a89e5bb2 100644
--- a/target/linux/omap/config-4.19
+++ b/target/linux/omap/config-4.19
@@ -240,7 +240,6 @@  CONFIG_EXTCON_PALMAS=y
 CONFIG_EXTCON_USB_GPIO=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FANOTIFY=y
 CONFIG_FAT_FS=y
 CONFIG_FB_CMDLINE=y
diff --git a/target/linux/sunxi/config-4.19 b/target/linux/sunxi/config-4.19
index 37b45c666da0..5f682d2c51b9 100644
--- a/target/linux/sunxi/config-4.19
+++ b/target/linux/sunxi/config-4.19
@@ -172,7 +172,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
diff --git a/target/linux/tegra/config-4.19 b/target/linux/tegra/config-4.19
index 0650783f8b39..86299a719689 100644
--- a/target/linux/tegra/config-4.19
+++ b/target/linux/tegra/config-4.19
@@ -197,7 +197,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y
diff --git a/target/linux/tegra/config-5.4 b/target/linux/tegra/config-5.4
index 968bcb46208b..6baedf035dc6 100644
--- a/target/linux/tegra/config-5.4
+++ b/target/linux/tegra/config-5.4
@@ -212,7 +212,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y
diff --git a/target/linux/x86/config-4.19 b/target/linux/x86/config-4.19
index 34c10ae40938..412fdf900b69 100644
--- a/target/linux/x86/config-4.19
+++ b/target/linux/x86/config-4.19
@@ -130,7 +130,6 @@  CONFIG_EDAC_SUPPORT=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 # CONFIG_F71808E_WDT is not set
 CONFIG_FIRMWARE_MEMMAP=y
 CONFIG_FIX_EARLYCON_MEM=y
diff --git a/target/linux/x86/config-5.4 b/target/linux/x86/config-5.4
index a2b18f33f0f8..66cca9600554 100644
--- a/target/linux/x86/config-5.4
+++ b/target/linux/x86/config-5.4
@@ -147,7 +147,6 @@  CONFIG_EFI_EARLYCON=y
 CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 # CONFIG_F71808E_WDT is not set
 CONFIG_FIRMWARE_MEMMAP=y
 CONFIG_FIX_EARLYCON_MEM=y
diff --git a/target/linux/zynq/config-4.19 b/target/linux/zynq/config-4.19
index c12bd5f8c18c..86033b031a9c 100644
--- a/target/linux/zynq/config-4.19
+++ b/target/linux/zynq/config-4.19
@@ -194,7 +194,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y
diff --git a/target/linux/zynq/config-5.4 b/target/linux/zynq/config-5.4
index d389a27a03ca..090846036e97 100644
--- a/target/linux/zynq/config-5.4
+++ b/target/linux/zynq/config-5.4
@@ -205,7 +205,6 @@  CONFIG_EXT4_FS=y
 CONFIG_EXTCON=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
-# CONFIG_F2FS_FS_SECURITY is not set
 CONFIG_FB=y
 CONFIG_FB_CFB_COPYAREA=y
 CONFIG_FB_CFB_FILLRECT=y