diff mbox series

[2/2] rules.mk: simplify FAKEROOT command line

Message ID 20200910125731.3415057-2-jo@mein.io
State Accepted
Delegated to: Jo-Philipp Wich
Headers show
Series [1/2] fakeroot: make fakeroot script relocatable | expand

Commit Message

Jo-Philipp Wich Sept. 10, 2020, 12:57 p.m. UTC
Since fakeroot is patched to discover related ressources relative to the
STAGING_DIR_HOST environment variable, there is no need to pass the path
to faked or the preload library manually anymore.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
 rules.mk | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

Comments

Jo-Philipp Wich Sept. 10, 2020, 1 p.m. UTC | #1
Hi,

please disregard, I made a logical mistake and forgot that the OS X check is
about the *.dylib vs. *.so extension, not the library location.

~ Jo
Jo-Philipp Wich Sept. 10, 2020, 1:04 p.m. UTC | #2
Hi again,
> please disregard, I made a logical mistake and forgot that the OS X check is
> about the *.dylib vs. *.so extension, not the library location.

actually it seems fine after all since the proper extension is embedded in the
fakeroot script according to whats applicable to the host system:

  LIB=lib@fakeroot_transformed@@DLSUFFIX@

Would still appreciate some runtime testing on OS X.

~ Jo
diff mbox series

Patch

diff --git a/rules.mk b/rules.mk
index 8b2424f2ba..3214395e1f 100644
--- a/rules.mk
+++ b/rules.mk
@@ -264,12 +264,7 @@  endif
 
 BUILD_KEY=$(TOPDIR)/key-build
 
-ifeq ($(HOST_OS),Darwin)
-  FAKEROOT_SO:=$(STAGING_DIR_HOST)/lib/libfakeroot.dylib
-else
-  FAKEROOT_SO:=$(STAGING_DIR_HOST)/lib/libfakeroot.so
-endif
-FAKEROOT:=$(STAGING_DIR_HOST)/bin/fakeroot -l $(FAKEROOT_SO) -f $(STAGING_DIR_HOST)/bin/faked
+FAKEROOT:=$(STAGING_DIR_HOST)/bin/fakeroot
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(TARGET_CROSS)g++