diff mbox series

ath10k-ct: update to version 2018-08-25

Message ID 20200901231433.414585-1-stijn@linux-ipv6.be
State Changes Requested
Delegated to: Stijn Tintel
Headers show
Series ath10k-ct: update to version 2018-08-25 | expand

Commit Message

Stijn Tintel Sept. 1, 2020, 11:14 p.m. UTC
And since we are using mac80211 5.8, let's also switch the ath10k-ct
driver to the new 5.8 version.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---
 package/kernel/ath10k-ct/Makefile                      | 10 +++++-----
 .../164-ath10k-commit-rates-from-mac80211.patch        |  6 +++---
 ...GPIO-controlling-support-for-various-chipsets.patch |  6 +++---
 .../202-ath10k-use-tpt-trigger-by-default.patch        |  2 +-
 .../205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch  |  2 +-
 5 files changed, 13 insertions(+), 13 deletions(-)

Comments

Sander Vanheule Sept. 2, 2020, 9:36 a.m. UTC | #1
On Wed, 2020-09-02 at 02:14 +0300, Stijn Tintel wrote:
> And since we are using mac80211 5.8, let's also switch the ath10k-ct
> driver to the new 5.8 version.
> 
> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>

Built and run-tested on ath79 (TP-Link EAP245 v3: qca9563+qca9982)

Tested-by: Sander Vanheule <sander@svanheule.net>
Hauke Mehrtens Sept. 2, 2020, 11:32 a.m. UTC | #2
On 9/2/20 1:14 AM, Stijn Tintel wrote:
> And since we are using mac80211 5.8, let's also switch the ath10k-ct
> driver to the new 5.8 version.
> 
> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
> ---
>  package/kernel/ath10k-ct/Makefile                      | 10 +++++-----
>  .../164-ath10k-commit-rates-from-mac80211.patch        |  6 +++---
>  ...GPIO-controlling-support-for-various-chipsets.patch |  6 +++---
>  .../202-ath10k-use-tpt-trigger-by-default.patch        |  2 +-
>  .../205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch  |  2 +-
>  5 files changed, 13 insertions(+), 13 deletions(-)
> 
> diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
> index 76077ec156..ad80c75eaf 100644
> --- a/package/kernel/ath10k-ct/Makefile
> +++ b/package/kernel/ath10k-ct/Makefile
> @@ -8,14 +8,14 @@ PKG_LICENSE_FILES:=
>  
>  PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
>  PKG_SOURCE_PROTO:=git
> -PKG_SOURCE_DATE:=2020-06-30
> -PKG_SOURCE_VERSION:=edfbf9161ab75e4831981284ab2d5b1b9fb6ef72
> -PKG_MIRROR_HASH:=98b7f88baea7314144fa8f8d141ad0dbbf2816f9606b0a89afb396761b558d14
> +PKG_SOURCE_DATE:=2020-08-25
> +PKG_SOURCE_VERSION:=13319ff0b5dc3c86e8313f49fca583b829878736
> +PKG_MIRROR_HASH:=4a082f9c5ee26fea1eb2f86382b9db4aecec268c918f43e9a0729a0433e262da
>  
> -# Build the 5.4 ath10k-ct driver version.  Other option is "-4.19".
> +# Build ath10k-ct driver version 5.8. Other options are "-4.19", "-5.4", "-5.7".
>  # Probably this should match as closely as
>  # possible to whatever mac80211 backports version is being used.
> -CT_KVER="-5.4"
> +CT_KVER="-5.8"

You have to update the patches to also apply to the 5.8 version,
currently they are only applied to the 5.4 version.

I would split this into two patches, one updating ath10k-ct to
2020-08-25 and then a 2. patch which switches to 5.8 and adds the
patches for 5.8 too.

Hauke
diff mbox series

Patch

diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 76077ec156..ad80c75eaf 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -8,14 +8,14 @@  PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2020-06-30
-PKG_SOURCE_VERSION:=edfbf9161ab75e4831981284ab2d5b1b9fb6ef72
-PKG_MIRROR_HASH:=98b7f88baea7314144fa8f8d141ad0dbbf2816f9606b0a89afb396761b558d14
+PKG_SOURCE_DATE:=2020-08-25
+PKG_SOURCE_VERSION:=13319ff0b5dc3c86e8313f49fca583b829878736
+PKG_MIRROR_HASH:=4a082f9c5ee26fea1eb2f86382b9db4aecec268c918f43e9a0729a0433e262da
 
-# Build the 5.4 ath10k-ct driver version.  Other option is "-4.19".
+# Build ath10k-ct driver version 5.8. Other options are "-4.19", "-5.4", "-5.7".
 # Probably this should match as closely as
 # possible to whatever mac80211 backports version is being used.
-CT_KVER="-5.4"
+CT_KVER="-5.8"
 
 PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
 PKG_BUILD_PARALLEL:=1
diff --git a/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch b/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
index 4e88c8a19f..b913bbdc82 100644
--- a/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
+++ b/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
@@ -11,7 +11,7 @@  Signed-off-by: Sven Eckelmann <sven@narfation.org>
 
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -6793,6 +6793,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6796,6 +6796,7 @@ static void ath10k_bss_info_changed(stru
  			   "mac vdev %d mcast_rate %x\n",
  			   arvif->vdev_id, rate);
  
@@ -19,7 +19,7 @@  Signed-off-by: Sven Eckelmann <sven@narfation.org>
  		vdev_param = ar->wmi.vdev_param->mcast_data_rate;
  		ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
  						vdev_param, rate);
-@@ -6801,6 +6802,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6804,6 +6805,7 @@ static void ath10k_bss_info_changed(stru
  				    "failed to set mcast rate on vdev %i: %d\n",
  				    arvif->vdev_id,  ret);
  
@@ -27,7 +27,7 @@  Signed-off-by: Sven Eckelmann <sven@narfation.org>
  		vdev_param = ar->wmi.vdev_param->bcast_data_rate;
  		ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
  						vdev_param, rate);
-@@ -6827,6 +6829,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6830,6 +6832,7 @@ static void ath10k_bss_info_changed(stru
  			return;
  		}
  
diff --git a/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch b/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
index 15343abd5f..5291732f25 100644
--- a/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
+++ b/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
@@ -396,7 +396,7 @@  v13:
  /* Rates */
 --- a/ath10k-5.4/wmi-ops.h
 +++ b/ath10k-5.4/wmi-ops.h
-@@ -218,7 +218,10 @@ struct wmi_ops {
+@@ -219,7 +219,10 @@ struct wmi_ops {
  	struct sk_buff *(*gen_bb_timing)
  			(struct ath10k *ar,
  			 const struct wmi_bb_timing_cfg_arg *arg);
@@ -407,7 +407,7 @@  v13:
  };
  
  int ath10k_wmi_cmd_send(struct ath10k *ar, struct sk_buff *skb, u32 cmd_id);
-@@ -1105,6 +1108,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
+@@ -1115,6 +1118,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
  	return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->force_fw_hang_cmdid);
  }
  
@@ -445,7 +445,7 @@  v13:
  {
 --- a/ath10k-5.4/wmi-tlv.c
 +++ b/ath10k-5.4/wmi-tlv.c
-@@ -4367,6 +4367,8 @@ static const struct wmi_ops wmi_tlv_ops
+@@ -4382,6 +4382,8 @@ static const struct wmi_ops wmi_tlv_ops
  	.gen_echo = ath10k_wmi_tlv_op_gen_echo,
  	.gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
  	.gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
diff --git a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
index dd35e2937c..838158c7e0 100644
--- a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
+++ b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
@@ -42,7 +42,7 @@  Signed-off-by: Mathias Kresin <dev@kresin.me>
  	if (ret)
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10383,7 +10383,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10386,7 +10386,7 @@ int ath10k_mac_register(struct ath10k *a
  	ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
diff --git a/package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch b/package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch
index 33d69e7975..09dd13e9a4 100644
--- a/package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch
+++ b/package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch
@@ -1,6 +1,6 @@ 
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10182,6 +10182,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10185,6 +10185,7 @@ int ath10k_mac_register(struct ath10k *a
  	wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_VHT_IBSS);
  	wiphy_ext_feature_set(ar->hw->wiphy,
  			      NL80211_EXT_FEATURE_SET_SCAN_DWELL);