diff mbox series

[2/3] build: sort default packages and split by newlines

Message ID 20200827214708.915775-2-mail@aparcar.org
State Accepted
Delegated to: Daniel Golle
Headers show
Series [1/3] build: add libustream and certs to default pkgs | expand

Commit Message

Paul Spooren Aug. 27, 2020, 9:47 p.m. UTC
The line of default packages became very long and it is easier to read
one package per line, therefore split it by newlines and sort it
alphabetically.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 include/target.mk | 35 ++++++++++++++++++++++++++++++++---
 1 file changed, 32 insertions(+), 3 deletions(-)

Comments

Karl Palsson Aug. 28, 2020, 9:14 a.m. UTC | #1
Paul Spooren <mail@aparcar.org> wrote:
> The line of default packages became very long and it is easier
> to read one package per line, therefore split it by newlines
> and sort it alphabetically.

If you're going to do that, why not use += as well, so you don't
have to worry about people getting the \ right, and adding
entries at the end doesn't break things?

DEFAULT_PACKAGES+=base-files
DEFAULT_PACKAGES+=busybox
DEFAULT_PACKAGES+=ca-bundle
.....


Sincerely,
Karl Palsson


> 
> Signed-off-by: Paul Spooren <mail@aparcar.org>
> ---
>  include/target.mk | 35 ++++++++++++++++++++++++++++++++---
>  1 file changed, 32 insertions(+), 3 deletions(-)
> 
> diff --git a/include/target.mk b/include/target.mk
> index b0c563a0ef..03550c6ca6 100644
> --- a/include/target.mk
> +++ b/include/target.mk
> @@ -13,13 +13,42 @@ __target_inc=1
>  DEVICE_TYPE?=router
>  
>  # Default packages - the really basic set
> -DEFAULT_PACKAGES:=base-files busybox ca-bundle dropbear
> fstools libc libgcc logd libustream-wolfssl mtd netifd opkg uci
> uclient-fetch urandom-seed urngd +DEFAULT_PACKAGES:=\
> +	base-files \
> +	busybox \
> +	ca-bundle \
> +	dropbear \
> +	fstools \
> +	libc \
> +	libgcc \
> +	libustream-wolfssl \
> +	logd \
> +	mtd \
> +	netifd \
> +	opkg \
> +	uci \
> +	uclient-fetch \
> +	urandom-seed \
> +	urngd
>  # For the basic set
>  DEFAULT_PACKAGES.basic:=
>  # For nas targets
> -DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
> +DEFAULT_PACKAGES.nas:=\
> +	block-mount \
> +	fdisk \
> +	lsblk \
> +	mdadm
>  # For router targets
> -DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp
> ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
> +DEFAULT_PACKAGES.router:=\
> +	dnsmasq \
> +	firewall \
> +	ip6tables \
> +	iptables \
> +	kmod-ipt-offload \
> +	odhcp6c \
> +	odhcpd-ipv6only \
> +	ppp \
> +	ppp-mod-pppoe
>  
>  ifneq ($(DUMP),)
>    all: dumpinfo
> -- 
> 2.25.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/include/target.mk b/include/target.mk
index b0c563a0ef..03550c6ca6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -13,13 +13,42 @@  __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files busybox ca-bundle dropbear fstools libc libgcc logd libustream-wolfssl mtd netifd opkg uci uclient-fetch urandom-seed urngd
+DEFAULT_PACKAGES:=\
+	base-files \
+	busybox \
+	ca-bundle \
+	dropbear \
+	fstools \
+	libc \
+	libgcc \
+	libustream-wolfssl \
+	logd \
+	mtd \
+	netifd \
+	opkg \
+	uci \
+	uclient-fetch \
+	urandom-seed \
+	urngd
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets
-DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
+DEFAULT_PACKAGES.nas:=\
+	block-mount \
+	fdisk \
+	lsblk \
+	mdadm
 # For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
+DEFAULT_PACKAGES.router:=\
+	dnsmasq \
+	firewall \
+	ip6tables \
+	iptables \
+	kmod-ipt-offload \
+	odhcp6c \
+	odhcpd-ipv6only \
+	ppp \
+	ppp-mod-pppoe
 
 ifneq ($(DUMP),)
   all: dumpinfo