diff mbox series

binutils: fix build after upgrade to 2.34

Message ID 20200810045106.GA1437018@imp.flyn.org
State Superseded
Delegated to: Hauke Mehrtens
Headers show
Series binutils: fix build after upgrade to 2.34 | expand

Commit Message

W. Michael Petullo Aug. 10, 2020, 4:51 a.m. UTC
From: "W. Michael Petullo" <mike@flyn.org>

Building the binutils package produced the following error:

Package binutils is missing dependencies for the following libraries:
libctf-nobfd.so.0

This changes the glob for the libctf subpackage so that it catches
libctf-nobfd.so.0.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
---
 package/devel/binutils/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Hauke Mehrtens Aug. 10, 2020, 10:25 p.m. UTC | #1
On 8/10/20 6:51 AM, W. Michael Petullo wrote:
> From: "W. Michael Petullo" <mike@flyn.org>
> 
> Building the binutils package produced the following error:
> 
> Package binutils is missing dependencies for the following libraries:
> libctf-nobfd.so.0
> 
> This changes the glob for the libctf subpackage so that it catches
> libctf-nobfd.so.0.
> 
> Signed-off-by: W. Michael Petullo <mike@flyn.org>
> ---
>  package/devel/binutils/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
> index 6ad326efa0..fada8009be 100644
> --- a/package/devel/binutils/Makefile
> +++ b/package/devel/binutils/Makefile
> @@ -106,7 +106,7 @@ endef
>  
>  define Package/libctf/install
>  	$(INSTALL_DIR) $(1)/usr/lib
> -	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
> +	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
>  endef
>  
>  define Package/libopcodes/install
> 

I already send this patch some hours before:
https://patchwork.ozlabs.org/project/openwrt/patch/20200809160216.23697-1-hauke@hauke-m.de/

It fixes the same problem.

Hauke
diff mbox series

Patch

diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 6ad326efa0..fada8009be 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -106,7 +106,7 @@  endef
 
 define Package/libctf/install
 	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
 endef
 
 define Package/libopcodes/install