diff mbox series

[3/4] build: image: remove strange useless comment

Message ID 20200806141241.34383-3-freifunk@adrianschmutzler.de
State Rejected
Delegated to: Adrian Schmutzler
Headers show
Series [1/4] mvebu: fix sysupgrade experience for early DSA-adopters | expand

Commit Message

Adrian Schmutzler Aug. 6, 2020, 2:12 p.m. UTC
This "comment" seems to be a leftover from some development work.

Remove it.

Fixes: 77265e00c70a ("build: add support code for appending metadata to images")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 include/image-commands.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jo-Philipp Wich Aug. 6, 2020, 2:33 p.m. UTC | #1
Hi Adrian,

>  compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
>  json_quote=$(subst ','\'',$(subst ",\",$(1)))
> -#")')

This commit was most likely added to aid text editors with naive syntax
highlighting capabilities that fail to properly detect the end of the string
due to the unique Make escape semantics. I'd propose to leave it in place.

If you want, you could prefix it with something like "fix bad syntax
highlighting: "

~ Jo
Adrian Schmutzler Aug. 6, 2020, 10:12 p.m. UTC | #2
> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Jo-Philipp Wich
> Sent: Donnerstag, 6. August 2020 16:34
> To: openwrt-devel@lists.openwrt.org
> Subject: Re: [PATCH 3/4] build: image: remove strange useless comment
> 
> Hi Adrian,
> 
> >  compat_version=$(if
> > $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
> >  json_quote=$(subst ','\'',$(subst ",\",$(1)))
> > -#")')
> 
> This commit was most likely added to aid text editors with naive syntax
> highlighting capabilities that fail to properly detect the end of the string due
> to the unique Make escape semantics. I'd propose to leave it in place.
> 
> If you want, you could prefix it with something like "fix bad syntax
> highlighting: "

I see. Thanks for the enlightenment.

I will just not touch it and drop the patch.

> 
> ~ Jo
diff mbox series

Patch

diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8ed705a7f4..089ed93c67 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -381,7 +381,7 @@  endef
 
 compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
 json_quote=$(subst ','\'',$(subst ",\",$(1)))
-#")')
+
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
 metadata_json = \
 	'{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \