diff mbox series

gettext-full: use included glib

Message ID 20200725012009.223148-1-rosenp@gmail.com
State Not Applicable, archived
Headers show
Series gettext-full: use included glib | expand

Commit Message

Rosen Penev July 25, 2020, 1:20 a.m. UTC
If gettext-full happens to be built after glib2/host, it picks up the
host build and tries to link to it with an inappropriate rpath. Instead
of working around the issue, just use the included glib to avoid it.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/libs/gettext-full/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index 2e65571701..b5699c33e3 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -9,7 +9,7 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
 PKG_VERSION:=0.19.8.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
@@ -69,8 +69,8 @@  HOST_CONFIGURE_ARGS += \
 	--disable-native-java \
 	--disable-openmp \
 	--without-emacs \
-	--without-libxml2-prefix
-
+	--without-libxml2-prefix \
+	--with-included-glib
 
 HOST_CONFIGURE_VARS += \
 	EMACS="no" \