diff mbox series

fstools: disable swapon/swapoff symlink creation

Message ID 20200715135638.48786-1-rsalvaterra@gmail.com
State Under Review
Delegated to: Rui Salvaterra
Headers show
Series fstools: disable swapon/swapoff symlink creation | expand

Commit Message

Rui Salvaterra July 15, 2020, 1:56 p.m. UTC
The swapon/swapoff applets enabled by default in BusyBox have more features than
the ones from block-mount's block app, which makes them redundant.

This patch removes disables the creation of the symlinks for the swapon/swapoff
block applets. A follow-up patch will remove the applets themselves from the
block executable.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/system/fstools/Makefile | 2 --
 1 file changed, 2 deletions(-)
diff mbox series

Patch

diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 6b813cb433..ed0b3a7a80 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -114,8 +114,6 @@  define Package/block-mount/install
 
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
 	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/
-	$(LN) ../../sbin/block $(1)/usr/sbin/swapon
-	$(LN) ../../sbin/block $(1)/usr/sbin/swapoff
 
 endef