diff mbox series

procd: don't let the user choose to mount /tmp on zram

Message ID 20200712174248.1479-1-rsalvaterra@gmail.com
State Superseded
Delegated to: Rui Salvaterra
Headers show
Series procd: don't let the user choose to mount /tmp on zram | expand

Commit Message

Rui Salvaterra July 12, 2020, 5:42 p.m. UTC
The /tmp directory is mounted as tmpfs. The tmpfs filesystem is backed by
anonymous memory, which means it can be swapped out at any time, if there is
memory pressure [1]. For this reason, a zram swap device is a much better
choice than mounting /tmp on zram, since it's able to compress all anonymous
memory, and not just the memory assigned to /tmp. We already have the zram-swap
package for this specific purpose, which means procd's tmp-on-zram is both
redundant and more limited.

For the time being, don't allow the user to select this feature. Follow-up
patches will remove procd tmp-on-zram support altogether.

[1] https://www.kernel.org/doc/Documentation/filesystems/tmpfs.txt

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/system/procd/Makefile | 1 -
 1 file changed, 1 deletion(-)
diff mbox series

Patch

diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 3b88c76144..78b2450a04 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -90,7 +90,6 @@  config PROCD_SHOW_BOOT
 config PROCD_ZRAM_TMPFS
 	bool
 	default n
-	prompt "Mount /tmp using zram."
 endmenu
 endef