diff mbox series

ath79: replace custom uImageArcher generation

Message ID 20200628162629.200982-1-mail@david-bauer.net
State Accepted
Delegated to: David Bauer
Headers show
Series ath79: replace custom uImageArcher generation | expand

Commit Message

David Bauer June 28, 2020, 4:26 p.m. UTC
The replaces the custom uImageArcher build step with the generic uImage
build step. The only different between these two is the difference in
the generated name.

Tested on: TP-Link Archer C59 v1

Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ath79/image/common-tp-link.mk | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)

Comments

Adrian Schmutzler June 28, 2020, 5:55 p.m. UTC | #1
> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of David Bauer
> Sent: Sonntag, 28. Juni 2020 18:26
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH] ath79: replace custom uImageArcher generation
> 
> The replaces the custom uImageArcher build step with the generic uImage
> build step. The only different between these two is the difference in the
> generated name.

Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>

> 
> Tested on: TP-Link Archer C59 v1
> 
> Signed-off-by: David Bauer <mail@david-bauer.net>
> ---
>  target/linux/ath79/image/common-tp-link.mk | 10 +---------
>  1 file changed, 1 insertion(+), 9 deletions(-)
> 
> diff --git a/target/linux/ath79/image/common-tp-link.mk
> b/target/linux/ath79/image/common-tp-link.mk
> index 81a557df48..ab10920402 100644
> --- a/target/linux/ath79/image/common-tp-link.mk
> +++ b/target/linux/ath79/image/common-tp-link.mk
> @@ -1,14 +1,6 @@
>  DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT
> TPLINK_HEADER_VERSION  DEVICE_VARS += TPLINK_BOARD_ID
> TPLINK_HWREVADD TPLINK_HVERSION
> 
> -define Build/uImageArcher
> -	mkimage -A $(LINUX_KARCH) \
> -		-O linux -T kernel -C $(1) -a $(KERNEL_LOADADDR) \
> -		-e $(if
> $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
> -		-n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-
> $(LINUX_VERSION)' -d $@ $@.new
> -	@mv $@.new $@
> -endef
> -
>  define Device/tplink-v1
>    DEVICE_VENDOR := TP-Link
>    TPLINK_HWID := 0x0
> @@ -86,7 +78,7 @@ endef
> 
>  define Device/tplink-safeloader-uimage
>    $(Device/tplink-safeloader)
> -  KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
> +  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
>    KERNEL_INITRAMFS := $$(KERNEL)
>  endef
> 
> --
> 2.27.0
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> http://lists.infradead.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 81a557df48..ab10920402 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -1,14 +1,6 @@ 
 DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION
 DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HWREVADD TPLINK_HVERSION
 
-define Build/uImageArcher
-	mkimage -A $(LINUX_KARCH) \
-		-O linux -T kernel -C $(1) -a $(KERNEL_LOADADDR) \
-		-e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-		-n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
-	@mv $@.new $@
-endef
-
 define Device/tplink-v1
   DEVICE_VENDOR := TP-Link
   TPLINK_HWID := 0x0
@@ -86,7 +78,7 @@  endef
 
 define Device/tplink-safeloader-uimage
   $(Device/tplink-safeloader)
-  KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
   KERNEL_INITRAMFS := $$(KERNEL)
 endef