diff mbox series

[OpenWrt-Devel] libconfig: remove

Message ID 20200522231647.64742-1-rosenp@gmail.com
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel] libconfig: remove | expand

Commit Message

Rosen Penev May 22, 2020, 11:16 p.m. UTC
No package in base uses libconfig. Everything is in the packages feed.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/libs/libconfig/Makefile | 60 ---------------------------------
 1 file changed, 60 deletions(-)
 delete mode 100644 package/libs/libconfig/Makefile

Comments

Rosen Penev May 22, 2020, 11:18 p.m. UTC | #1
On Fri, May 22, 2020 at 4:16 PM Rosen Penev <rosenp@gmail.com> wrote:
>
> No package in base uses libconfig. Everything is in the packages feed.
https://github.com/openwrt/packages/pull/12255
>
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
>  package/libs/libconfig/Makefile | 60 ---------------------------------
>  1 file changed, 60 deletions(-)
>  delete mode 100644 package/libs/libconfig/Makefile
>
> diff --git a/package/libs/libconfig/Makefile b/package/libs/libconfig/Makefile
> deleted file mode 100644
> index 39fcddf082..0000000000
> --- a/package/libs/libconfig/Makefile
> +++ /dev/null
> @@ -1,60 +0,0 @@
> -#
> -# Copyright (C) 2008-2012 OpenWrt.org
> -#
> -# This is free software, licensed under the GNU General Public License v2.
> -# See /LICENSE for more information.
> -#
> -
> -include $(TOPDIR)/rules.mk
> -
> -PKG_NAME:=libconfig
> -PKG_VERSION:=1.7.2
> -PKG_RELEASE:=2
> -
> -PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
> -PKG_SOURCE_URL:=https://hyperrealm.github.io/libconfig/dist/
> -PKG_HASH:=7c3c7a9c73ff3302084386e96f903eb62ce06953bb1666235fac74363a16fad9
> -
> -PKG_FIXUP:=autoreconf
> -PKG_INSTALL:=1
> -
> -PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
> -PKG_LICENSE:=LGPL-2.1+
> -
> -include $(INCLUDE_DIR)/package.mk
> -
> -define Package/libconfig
> -  SECTION:=libs
> -  CATEGORY:=Libraries
> -  TITLE:=Configuration File Library
> -  URL:=http://www.hyperrealm.com/libconfig/
> -  ABI_VERSION:=11
> -endef
> -
> -define Package/libconfig/description
> - Libconfig is a simple library for manipulating structured configuration
> - files. This file format is more compact and more readable than XML. And
> - unlike XML, it is type-aware, so it is not necessary to do string
> - parsing in application code.
> -
> - Libconfig is very compact -- just 38K for the stripped C shared
> - library (less than one-fourth the size of the expat XML parser library)
> - and 66K for the stripped C++ shared library. This makes it well-suited
> - for memory-constrained systems like handheld devices.
> -endef
> -
> -CONFIGURE_ARGS += \
> -       --enable-shared \
> -       --disable-static \
> -       --disable-cxx
> -
> -define Build/InstallDev
> -       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
> -endef
> -
> -define Package/libconfig/install
> -       $(INSTALL_DIR) $(1)/usr/lib
> -       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so.* $(1)/usr/lib/
> -endef
> -
> -$(eval $(call BuildPackage,libconfig))
> --
> 2.26.2
>
diff mbox series

Patch

diff --git a/package/libs/libconfig/Makefile b/package/libs/libconfig/Makefile
deleted file mode 100644
index 39fcddf082..0000000000
--- a/package/libs/libconfig/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@ 
-#
-# Copyright (C) 2008-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libconfig
-PKG_VERSION:=1.7.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://hyperrealm.github.io/libconfig/dist/
-PKG_HASH:=7c3c7a9c73ff3302084386e96f903eb62ce06953bb1666235fac74363a16fad9
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-PKG_LICENSE:=LGPL-2.1+
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libconfig
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Configuration File Library
-  URL:=http://www.hyperrealm.com/libconfig/
-  ABI_VERSION:=11
-endef
-
-define Package/libconfig/description
- Libconfig is a simple library for manipulating structured configuration
- files. This file format is more compact and more readable than XML. And
- unlike XML, it is type-aware, so it is not necessary to do string
- parsing in application code.
-
- Libconfig is very compact -- just 38K for the stripped C shared
- library (less than one-fourth the size of the expat XML parser library)
- and 66K for the stripped C++ shared library. This makes it well-suited
- for memory-constrained systems like handheld devices.
-endef
-
-CONFIGURE_ARGS += \
-	--enable-shared \
-	--disable-static \
-	--disable-cxx
-
-define Build/InstallDev
-	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
-
-define Package/libconfig/install
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libconfig))