diff mbox series

[OpenWrt-Devel] ath79: nand: disable images for glinet_gl-ar750s

Message ID 20200520105913.29246-1-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel] ath79: nand: disable images for glinet_gl-ar750s | expand

Commit Message

Petr Štetiar May 20, 2020, 10:59 a.m. UTC
Seems like kernel doesn't fit into 2M anymore. Fixes following build failures:

 WARNING: Image file glinet_gl-ar750s-nor-kernel.bin is too big
 WARNING: Image file glinet_gl-ar750s-nor-nand-kernel.bin is too big

Cc: Jeff Kletsky <git-commits@allycomm.com>
Cc: Chuanhong Guo <gch981213@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 target/linux/ath79/image/nand.mk | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 76fee34a90e1..a68f3900d16c 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -134,6 +134,7 @@  define Device/glinet_gl-ar750s-nor-nand
 	append-ubi | check-kernel-size $$$$(GL_UBOOT_UBI_OFFSET)
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   SUPPORTED_DEVICES += glinet,gl-ar750s-nor
+  DEFAULT := n
 endef
 TARGET_DEVICES += glinet_gl-ar750s-nor-nand
 
@@ -142,6 +143,7 @@  define Device/glinet_gl-ar750s-nor
   DEVICE_VARIANT := NOR
   BLOCKSIZE := 64k
   SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s glinet,gl-ar750s-nor-nand
+  DEFAULT := n
 endef
 TARGET_DEVICES += glinet_gl-ar750s-nor