diff mbox series

[OpenWrt-Devel,02/11] generic: routerboot partition build bits (4.19)

Message ID 20200328142032.37734-3-hacks@slashdirt.org
State Superseded
Delegated to: Koen Vandeputte
Headers show
Series MTD parser for RouterBoot partitions | expand

Commit Message

Thibaut March 28, 2020, 2:20 p.m. UTC
Signed-off-by: Thibaut VARĂˆNE <hacks@slashdirt.org>
---
 .../435-mtd-add-routerbootpart-parser-config.patch | 25 ++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
diff mbox series

Patch

diff --git a/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
new file mode 100644
index 0000000000..2cc91179b1
--- /dev/null
+++ b/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
@@ -0,0 +1,25 @@ 
+diff --git a/drivers/mtd/parsers/Kconfig b/drivers/mtd/parsers/Kconfig
+index de6f5f8..0afa89c 100644
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -22,3 +22,12 @@ config MTD_SHARPSL_PARTS
+ 	  This provides the read-only FTL logic necessary to read the partition
+ 	  table from the NAND flash of Sharp SL Series (Zaurus) and the MTD
+ 	  partition parser using this code.
++
++config MTD_ROUTERBOOT_PARTS
++	tristate "RouterBoot flash partition parser"
++	depends on MTD && OF
++	help
++	  MikroTik RouterBoot is implemented as a multi segment system on the
++	  flash, some of which are fixed and some of which are located at
++	  variable offsets. This parser handles both cases via properly
++	  formatted DTS.
+diff --git a/drivers/mtd/parsers/Makefile b/drivers/mtd/parsers/Makefile
+index 44ff342..0543362 100644
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,2 +1,3 @@
+ obj-$(CONFIG_MTD_PARSER_TRX)		+= parser_trx.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS)		+= sharpslpart.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)		+= routerbootpart.o