diff mbox series

[OpenWrt-Devel,6/6] scripts: fixup qemustart for new x86 image names

Message ID 20200320101059.19793-7-mail@aparcar.org
State Accepted
Delegated to: Daniel Golle
Headers show
Series x86: switch to generic image generation code | expand

Commit Message

Paul Spooren March 20, 2020, 10:10 a.m. UTC
qemustart allows easy testing of created images via `qemu`. The script
automatically selects created images and can setup e.g. networks.

As the x86 target now uses the generic image.mk the profile appears also
in the image name, this is *generic*.

Add the profile name to the qemustart script so it still finds the file.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 scripts/qemustart | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/scripts/qemustart b/scripts/qemustart
index dbb8deddaf..9ce03901aa 100755
--- a/scripts/qemustart
+++ b/scripts/qemustart
@@ -255,7 +255,7 @@  start_qemu_x86() {
 	local mach="${o_mach:-pc}"
 
 	[ -n "$rootfs" ] || {
-		rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-combined-ext4.img"
+		rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-generic-ext4-combined.img"
 		if [ ! -f "$rootfs" -a -s "$rootfs.gz" ]; then
 			gunzip "$rootfs.gz"
 		fi