diff mbox series

[OpenWrt-Devel,5/9] sunxi: a53: image: make it DRY

Message ID 20200318222713.1495-6-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series sunxi: add support for Olimex A64-Olinuxino | expand

Commit Message

Petr Štetiar March 18, 2020, 10:27 p.m. UTC
Replace same copy&pasted lines with the appropriate reusable bits.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 target/linux/sunxi/image/cortex-a53.mk | 46 ++++++++++++--------------
 1 file changed, 22 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index eeaaa887d7f2..79dd43c60fa3 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -6,14 +6,27 @@ 
 # See /LICENSE for more information.
 #
 
+define Device/sun50i
+  SUNXI_DTS_DIR := allwinner/
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+define Device/sun50i-h5
+  SOC := sun50i-h5
+  $(Device/sun50i)
+endef
+
+define Device/sun50i-a64
+  SOC := sun50i-a64
+  $(Device/sun50i)
+endef
+
 define Device/friendlyarm_nanopi-neo-plus2
   DEVICE_VENDOR := FriendlyARM
   DEVICE_MODEL := NanoPi NEO Plus2
   SUPPORTED_DEVICES:=nanopi-neo-plus2
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-h5
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-h5)
 endef
 TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
 
@@ -21,49 +34,34 @@  define Device/friendlyarm_nanopi-neo2
   DEVICE_VENDOR := FriendlyARM
   DEVICE_MODEL := NanoPi NEO2
   SUPPORTED_DEVICES:=nanopi-neo2
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-h5
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-h5)
 endef
 TARGET_DEVICES += friendlyarm_nanopi-neo2
 
 define Device/pine64_pine64-plus
   DEVICE_VENDOR := Pine64
   DEVICE_MODEL := Pine64+
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-a64
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-a64)
 endef
 TARGET_DEVICES += pine64_pine64-plus
 
 define Device/pine64_sopine-baseboard
   DEVICE_VENDOR := Pine64
   DEVICE_MODEL := SoPine
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-a64
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-a64)
 endef
 TARGET_DEVICES += pine64_sopine-baseboard
 
 define Device/xunlong_orangepi-pc2
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC 2
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-h5
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-h5)
 endef
 TARGET_DEVICES += xunlong_orangepi-pc2
 
 define Device/xunlong_orangepi-zero-plus
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi Zero Plus
-  SUNXI_DTS_DIR := allwinner/
-  SOC := sun50i-h5
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
+  $(Device/sun50i-h5)
 endef
 TARGET_DEVICES += xunlong_orangepi-zero-plus