diff mbox series

[OpenWrt-Devel] uboot-envtools: mxs: add support for olimex, imx23-olinuxino

Message ID 20200304224202.6691-1-mhei@heimpold.de
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel] uboot-envtools: mxs: add support for olimex, imx23-olinuxino | expand

Commit Message

Michael Heimpold March 4, 2020, 10:42 p.m. UTC
Add ubootenv uci config for Olimex OLinuXino boards.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
 package/boot/uboot-envtools/Makefile  | 2 +-
 package/boot/uboot-envtools/files/mxs | 3 +++
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 1c6b789716..49d57e69bd 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,7 @@  include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2019.07
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
diff --git a/package/boot/uboot-envtools/files/mxs b/package/boot/uboot-envtools/files/mxs
index ecfb5de162..e087d60783 100644
--- a/package/boot/uboot-envtools/files/mxs
+++ b/package/boot/uboot-envtools/files/mxs
@@ -17,6 +17,9 @@  i2se,duckbill)
 	ubootenv_add_uci_config "/dev/mmcblk0" "0x20000" "0x20000"
 	ubootenv_add_uci_config "/dev/mmcblk0" "0x40000" "0x20000"
 	;;
+olimex,imx23-olinuxino)
+	ubootenv_add_uci_config "/dev/mmcblk0" "0x40000" "0x4000"
+	;;
 esac
 
 config_load ubootenv