diff mbox series

[OpenWrt-Devel,4/4] brcm63xx: align DTS model with Makefile and compatible

Message ID 20191230232747.5357-5-freifunk@adrianschmutzler.de
State Superseded
Delegated to: Adrian Schmutzler
Headers show
Series brcm63xx: soc_vendor_model scheme and board_name removal | expand

Commit Message

Adrian Schmutzler Dec. 30, 2019, 11:27 p.m. UTC
Since the model string in DTS is not required to derive board name
anymore, we can now align it with the model name in Makefile and
the compatible.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/brcm63xx/dts/bcm6318_sagem_fast-2704n.dts    | 2 +-
 target/linux/brcm63xx/dts/bcm6328_sagem_fast-2704-v2.dts  | 2 +-
 target/linux/brcm63xx/dts/bcm6348_bt_voyager-2500v-bb.dts | 2 +-
 target/linux/brcm63xx/dts/bcm6348_sagem_fast-2404.dts     | 2 +-
 target/linux/brcm63xx/dts/bcm6348_sagem_fast-2604.dts     | 2 +-
 .../linux/brcm63xx/dts/bcm6348_t-com_speedport-w-500v.dts | 2 +-
 target/linux/brcm63xx/dts/bcm6348_usrobotics_usr9108.dts  | 2 +-
 .../brcm63xx/dts/bcm6358_sfr_neufbox-4-foxconn-r1.dts     | 2 +-
 .../brcm63xx/dts/bcm6358_sfr_neufbox-4-sercomm-r0.dts     | 2 +-
 .../linux/brcm63xx/dts/bcm6358_t-com_speedport-w-303v.dts | 2 +-
 target/linux/brcm63xx/dts/bcm6362_sagem_fast-2504n.dts    | 2 +-
 .../brcm63xx/dts/bcm6362_sfr_neufbox-6-sercomm-r0.dts     | 2 +-
 .../linux/brcm63xx/dts/bcm6368_huawei_echolife-hg622.dts  | 2 +-
 .../linux/brcm63xx/dts/bcm6368_huawei_echolife-hg655b.dts | 2 +-
 target/linux/brcm63xx/image/bcm63xx.mk                    | 8 ++++----
 15 files changed, 18 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/brcm63xx/dts/bcm6318_sagem_fast-2704n.dts b/target/linux/brcm63xx/dts/bcm6318_sagem_fast-2704n.dts
index 3ceddd09a2..f09310e2bb 100644
--- a/target/linux/brcm63xx/dts/bcm6318_sagem_fast-2704n.dts
+++ b/target/linux/brcm63xx/dts/bcm6318_sagem_fast-2704n.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Sagem F@ST2704N";
+	model = "Sagem F@st 2704N";
 	compatible = "sagem,fast-2704n", "brcm,bcm6318";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6328_sagem_fast-2704-v2.dts b/target/linux/brcm63xx/dts/bcm6328_sagem_fast-2704-v2.dts
index 1fe0d44810..d00d8fb4e5 100644
--- a/target/linux/brcm63xx/dts/bcm6328_sagem_fast-2704-v2.dts
+++ b/target/linux/brcm63xx/dts/bcm6328_sagem_fast-2704-v2.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Sagem F@ST2704V2";
+	model = "Sagem F@st 2704 V2";
 	compatible = "sagem,fast-2704-v2", "brcm,bcm6328";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6348_bt_voyager-2500v-bb.dts b/target/linux/brcm63xx/dts/bcm6348_bt_voyager-2500v-bb.dts
index a77362f2f6..0975cffd65 100644
--- a/target/linux/brcm63xx/dts/bcm6348_bt_voyager-2500v-bb.dts
+++ b/target/linux/brcm63xx/dts/bcm6348_bt_voyager-2500v-bb.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "BT Voyager V2500V";
+	model = "BT Voyager 2500V";
 	compatible = "bt,voyager-2500v-bb", "brcm,bcm6348";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2404.dts b/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2404.dts
index 60b945555b..945fcc1f18 100644
--- a/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2404.dts
+++ b/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2404.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Sagem F@ST2404";
+	model = "Sagem F@st 2404";
 	compatible = "sagem,fast-2404", "brcm,bcm6348";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2604.dts b/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2604.dts
index a3394dd70d..a2d2717575 100644
--- a/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2604.dts
+++ b/target/linux/brcm63xx/dts/bcm6348_sagem_fast-2604.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Sagem F@ST2604";
+	model = "Sagem F@st 2604";
 	compatible = "sagem,fast-2604", "brcm,bcm6348";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6348_t-com_speedport-w-500v.dts b/target/linux/brcm63xx/dts/bcm6348_t-com_speedport-w-500v.dts
index aa2f337253..8b0d1cacfd 100644
--- a/target/linux/brcm63xx/dts/bcm6348_t-com_speedport-w-500v.dts
+++ b/target/linux/brcm63xx/dts/bcm6348_t-com_speedport-w-500v.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "T-Com Speedport W500 V";
+	model = "T-Com Speedport W 500V";
 	compatible = "t-com,speedport-w-500v", "brcm,bcm6348";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6348_usrobotics_usr9108.dts b/target/linux/brcm63xx/dts/bcm6348_usrobotics_usr9108.dts
index 35ce1b010d..366eaf3bcd 100644
--- a/target/linux/brcm63xx/dts/bcm6348_usrobotics_usr9108.dts
+++ b/target/linux/brcm63xx/dts/bcm6348_usrobotics_usr9108.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "USRobotics 9108";
+	model = "USRobotics USR9108";
 	compatible = "usrobotics,usr9108", "brcm,bcm6348";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-foxconn-r1.dts b/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-foxconn-r1.dts
index e1a3046c7f..de22658843 100644
--- a/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-foxconn-r1.dts
+++ b/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-foxconn-r1.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "SFR Neuf Box 4 (Foxconn)";
+	model = "SFR Neufbox 4 (Foxconn)";
 	compatible = "sfr,neufbox-4-foxconn-r1", "brcm,bcm6358";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-sercomm-r0.dts b/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-sercomm-r0.dts
index b28aaa3fe7..db6c5f3306 100644
--- a/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-sercomm-r0.dts
+++ b/target/linux/brcm63xx/dts/bcm6358_sfr_neufbox-4-sercomm-r0.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "SFR Neuf Box 4 (Sercomm)";
+	model = "SFR Neufbox 4 (Sercomm)";
 	compatible = "sfr,neufbox-4-sercomm-r0", "brcm,bcm6358";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6358_t-com_speedport-w-303v.dts b/target/linux/brcm63xx/dts/bcm6358_t-com_speedport-w-303v.dts
index 68f8588f55..4aed5f0eb6 100644
--- a/target/linux/brcm63xx/dts/bcm6358_t-com_speedport-w-303v.dts
+++ b/target/linux/brcm63xx/dts/bcm6358_t-com_speedport-w-303v.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "T-Com Speedport W303 V";
+	model = "T-Com Speedport W 303V";
 	compatible = "t-com,speedport-w-303v", "brcm,bcm6358";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6362_sagem_fast-2504n.dts b/target/linux/brcm63xx/dts/bcm6362_sagem_fast-2504n.dts
index d1bf98a2b1..db8ce7318f 100644
--- a/target/linux/brcm63xx/dts/bcm6362_sagem_fast-2504n.dts
+++ b/target/linux/brcm63xx/dts/bcm6362_sagem_fast-2504n.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Sagem F@ST2504n";
+	model = "Sagem F@st 2504N";
 	compatible = "sagem,fast-2504n", "brcm,bcm6362";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6362_sfr_neufbox-6-sercomm-r0.dts b/target/linux/brcm63xx/dts/bcm6362_sfr_neufbox-6-sercomm-r0.dts
index a5184ff555..031aff0748 100644
--- a/target/linux/brcm63xx/dts/bcm6362_sfr_neufbox-6-sercomm-r0.dts
+++ b/target/linux/brcm63xx/dts/bcm6362_sfr_neufbox-6-sercomm-r0.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "SFR neufbox 6 (Sercomm)";
+	model = "SFR Neufbox 6 (Sercomm)";
 	compatible = "sfr,neufbox-6-sercomm-r0", "brcm,bcm6362";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg622.dts b/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg622.dts
index 36598645a3..77ecc62abd 100644
--- a/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg622.dts
+++ b/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg622.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Huawei HG622";
+	model = "Huawei EchoLife HG622";
 	compatible = "huawei,echolife-hg622", "brcm,bcm6368";
 
 	chosen {
diff --git a/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg655b.dts b/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg655b.dts
index 10fdcc6fd1..3f855bf0c9 100644
--- a/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg655b.dts
+++ b/target/linux/brcm63xx/dts/bcm6368_huawei_echolife-hg655b.dts
@@ -5,7 +5,7 @@ 
 #include <dt-bindings/input/input.h>
 
 / {
-	model = "Huawei HG655b";
+	model = "Huawei EchoLife HG655b";
 	compatible = "huawei,echolife-hg655b", "brcm,bcm6368";
 
 	chosen {
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 8c58c25617..f6937d6787 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -974,7 +974,7 @@  TARGET_DEVICES += sercomm_ad1018-nor
 define Device/sfr_neufbox-4-sercomm-r0
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox4
+  DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Sercomm
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
@@ -986,7 +986,7 @@  TARGET_DEVICES += sfr_neufbox-4-sercomm-r0
 define Device/sfr_neufbox-4-foxconn-r1
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox4
+  DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Foxconn
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
@@ -998,7 +998,7 @@  TARGET_DEVICES += sfr_neufbox-4-foxconn-r1
 define Device/sfr_neufbox-6-sercomm-r0
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox6
+  DEVICE_MODEL := Neufbox 6
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
@@ -1121,7 +1121,7 @@  TARGET_DEVICES += tp-link_td-w8900gb
 define Device/usrobotics_usr9108
   $(Device/bcm63xx)
   DEVICE_VENDOR := USRobotics
-  DEVICE_MODEL := 9108
+  DEVICE_MODEL := USR9108
   CFE_BOARD_ID := 96348GW-A
   CFE_CHIP_ID := 6348
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)