diff mbox series

[OpenWrt-Devel,v2,04/12] tools/libjson-c: new package

Message ID 20191121162322.671035-5-thomas.petazzoni@bootlin.com
State Rejected, archived
Headers show
Series dm-verity support | expand

Commit Message

Thomas Petazzoni Nov. 21, 2019, 4:23 p.m. UTC
libjson-c is needed to build cryptsetup. While the host variant of
libjson-c is already packaged in package/libs/libjson-c, we apparently
can't express a dependency of something packaged in "tools/" against a
library in package/libs/, so we have to duplicate libjson-c's
Makefile in tools/libjson-c/.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 tools/libjson-c/Makefile | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 tools/libjson-c/Makefile
diff mbox series

Patch

diff --git a/tools/libjson-c/Makefile b/tools/libjson-c/Makefile
new file mode 100644
index 0000000000..244594debc
--- /dev/null
+++ b/tools/libjson-c/Makefile
@@ -0,0 +1,25 @@ 
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=json-c
+PKG_VERSION:=0.13.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
+PKG_HASH:=b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))