diff mbox series

[OpenWrt-Devel,1/2] ath79: Remove legacy GL.iNet GL-AR300M NAND target

Message ID 20191025035501.3063-2-lede@allycomm.com
State Superseded
Headers show
Series ath79: Prepare NAND subtarget for upstream support of SPI | expand

Commit Message

Jeff Kletsky Oct. 25, 2019, 3:55 a.m. UTC
From: Jeff Kletsky <git-commits@allycomm.com>

Remove the sole board on the legacy ath79 NAND target
to clarify patches that will reintroduce support
on the MTD SPI-NAND framework present in Linux 4.19

Cc: Marty E. Plummer <hanetzer@startmail.com>

Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
---
 package/boot/uboot-envtools/files/ath79       |  1 -
 .../ath79/base-files/etc/board.d/01_leds      |  1 -
 .../dts/qca9531_glinet_gl-ar300m-nand.dts     | 34 -------------------
 target/linux/ath79/image/nand.mk              | 15 --------
 4 files changed, 51 deletions(-)
 delete mode 100644 target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts

Comments

Adrian Schmutzler Oct. 28, 2019, 11:42 a.m. UTC | #1
Hi,

after the recent changes (base-files split, new nand devices), I don't see a benefit anymore in removing ar300m-nand first and then adding it again.

I'd vote for removing this patch and doing the small remainder of it in "ath79: GL-AR300M: Provide NAND support", as this will be clearer _now_.

Best

Adrian

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org] On Behalf Of Jeff Kletsky
> Sent: Freitag, 25. Oktober 2019 05:55
> To: openwrt-devel@lists.openwrt.org
> Cc: Marty E . Plummer <hanetzer@startmail.com>; Jeff Kletsky <git-commits@allycomm.com>
> Subject: [OpenWrt-Devel] [PATCH 1/2] ath79: Remove legacy GL.iNet GL-AR300M NAND target
> 
> From: Jeff Kletsky <git-commits@allycomm.com>
> 
> Remove the sole board on the legacy ath79 NAND target
> to clarify patches that will reintroduce support
> on the MTD SPI-NAND framework present in Linux 4.19
> 
> Cc: Marty E. Plummer <hanetzer@startmail.com>
> 
> Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
> ---
>  package/boot/uboot-envtools/files/ath79       |  1 -
>  .../ath79/base-files/etc/board.d/01_leds      |  1 -
>  .../dts/qca9531_glinet_gl-ar300m-nand.dts     | 34 -------------------
>  target/linux/ath79/image/nand.mk              | 15 --------
>  4 files changed, 51 deletions(-)
>  delete mode 100644 target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts
> 
> diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
> index d5b94823fd..c0d131142d 100644
> --- a/package/boot/uboot-envtools/files/ath79
> +++ b/package/boot/uboot-envtools/files/ath79
> @@ -17,7 +17,6 @@ alfa-network,ap121f|\
>  buffalo,bhr-4grv2|\
>  engenius,ecb1750|\
>  glinet,gl-ar300m-lite|\
> -glinet,gl-ar300m-nand|\
>  glinet,gl-ar300m-nor|\
>  librerouter,librerouter-v1|\
>  netgear,ex6400|\
> diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
> index 499fe0031c..5beba7665c 100755
> --- a/target/linux/ath79/base-files/etc/board.d/01_leds
> +++ b/target/linux/ath79/base-files/etc/board.d/01_leds
> @@ -101,7 +101,6 @@ glinet,gl-ar150)
>  	ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth1"
>  	ucidef_set_led_switch "lan" "LAN" "$boardname:green:lan" "switch0" "0x02"
>  	;;
> -glinet,gl-ar300m-nand|\
>  glinet,gl-ar300m-nor)
>  	ucidef_set_led_netdev "lan" "LAN" "gl-ar300m:green:lan" "eth0"
>  	;;
> diff --git a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts b/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts
> deleted file mode 100644
> index 26c30f2b72..0000000000
> --- a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts
> +++ /dev/null
> @@ -1,34 +0,0 @@
> -/dts-v1/;
> -
> -#include "qca9531_glinet_gl-ar300m.dtsi"
> -
> -/ {
> -	compatible = "glinet,gl-ar300m-nand", "qca,qca9531";
> -	model = "GL.iNet GL-AR300M (NAND)";
> -};
> -
> -&spi {
> -	num-cs = <1>;
> -
> -	flash@1 {
> -		compatible = "spinand,mt29f";
> -		reg = <1>;
> -		spi-max-frequency = <25000000>;
> -
> -		partitions {
> -			compatible = "fixed-partitions";
> -			#address-cells = <1>;
> -			#size-cells = <1>;
> -
> -			partition@0 {
> -				label = "kernel";
> -				reg = <0x000000 0x0200000>;
> -			};
> -
> -			partition@1 {
> -				label = "ubi";
> -				reg = <0x200000 0x7e00000>;
> -			};
> -		};
> -	};
> -};
> diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
> index db4ff9c6f0..e69de29bb2 100644
> --- a/target/linux/ath79/image/nand.mk
> +++ b/target/linux/ath79/image/nand.mk
> @@ -1,15 +0,0 @@
> -define Device/glinet_gl-ar300m-nand
> -  ATH_SOC := qca9531
> -  DEVICE_VENDOR := GL.iNet
> -  DEVICE_MODEL := GL-AR300M
> -  DEVICE_VARIANT := NAND
> -  DEVICE_PACKAGES := kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
> -  KERNEL_SIZE := 2048k
> -  BLOCKSIZE := 128k
> -  PAGESIZE := 2048
> -  VID_HDR_OFFSET := 512
> -  IMAGES += factory.ubi
> -  IMAGE/sysupgrade.bin := sysupgrade-tar
> -  IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
> -endef
> -TARGET_DEVICES += glinet_gl-ar300m-nand
> --
> 2.20.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
index d5b94823fd..c0d131142d 100644
--- a/package/boot/uboot-envtools/files/ath79
+++ b/package/boot/uboot-envtools/files/ath79
@@ -17,7 +17,6 @@  alfa-network,ap121f|\
 buffalo,bhr-4grv2|\
 engenius,ecb1750|\
 glinet,gl-ar300m-lite|\
-glinet,gl-ar300m-nand|\
 glinet,gl-ar300m-nor|\
 librerouter,librerouter-v1|\
 netgear,ex6400|\
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 499fe0031c..5beba7665c 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -101,7 +101,6 @@  glinet,gl-ar150)
 	ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth1"
 	ucidef_set_led_switch "lan" "LAN" "$boardname:green:lan" "switch0" "0x02"
 	;;
-glinet,gl-ar300m-nand|\
 glinet,gl-ar300m-nor)
 	ucidef_set_led_netdev "lan" "LAN" "gl-ar300m:green:lan" "eth0"
 	;;
diff --git a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts b/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts
deleted file mode 100644
index 26c30f2b72..0000000000
--- a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts
+++ /dev/null
@@ -1,34 +0,0 @@ 
-/dts-v1/;
-
-#include "qca9531_glinet_gl-ar300m.dtsi"
-
-/ {
-	compatible = "glinet,gl-ar300m-nand", "qca,qca9531";
-	model = "GL.iNet GL-AR300M (NAND)";
-};
-
-&spi {
-	num-cs = <1>;
-
-	flash@1 {
-		compatible = "spinand,mt29f";
-		reg = <1>;
-		spi-max-frequency = <25000000>;
-
-		partitions {
-			compatible = "fixed-partitions";
-			#address-cells = <1>;
-			#size-cells = <1>;
-
-			partition@0 {
-				label = "kernel";
-				reg = <0x000000 0x0200000>;
-			};
-
-			partition@1 {
-				label = "ubi";
-				reg = <0x200000 0x7e00000>;
-			};
-		};
-	};
-};
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index db4ff9c6f0..e69de29bb2 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,15 +0,0 @@ 
-define Device/glinet_gl-ar300m-nand
-  ATH_SOC := qca9531
-  DEVICE_VENDOR := GL.iNet
-  DEVICE_MODEL := GL-AR300M
-  DEVICE_VARIANT := NAND
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
-  KERNEL_SIZE := 2048k
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  VID_HDR_OFFSET := 512
-  IMAGES += factory.ubi
-  IMAGE/sysupgrade.bin := sysupgrade-tar
-  IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
-endef
-TARGET_DEVICES += glinet_gl-ar300m-nand