diff mbox series

[OpenWrt-Devel] uboot-mxs: bump to v2019.07

Message ID 20190731214247.11683-1-mhei@heimpold.de
State Superseded, archived
Delegated to: Zoltan HERPAI
Headers show
Series [OpenWrt-Devel] uboot-mxs: bump to v2019.07 | expand

Commit Message

Michael Heimpold July 31, 2019, 9:42 p.m. UTC
Also update the U-Boot BSP patch for I2SE Duckbill devices.

Run tested on I2SE Duckbill and Olimex OLinuXino Maxi boards.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
 package/boot/uboot-mxs/Makefile                     |  4 ++--
 .../uboot-mxs/patches/001-add-i2se-duckbill.patch   | 13 +++++++------
 2 files changed, 9 insertions(+), 8 deletions(-)

Comments

Michael Heimpold Aug. 21, 2019, 6:34 p.m. UTC | #1
Hi wigyori,

Am Mittwoch, 31. Juli 2019, 23:42:45 CEST schrieb Michael Heimpold:
> Also update the U-Boot BSP patch for I2SE Duckbill devices.
> 
> Run tested on I2SE Duckbill and Olimex OLinuXino Maxi boards.

any objections on this patch?

Regards,
mhei

> 
> Signed-off-by: Michael Heimpold <mhei@heimpold.de>
> ---
>  package/boot/uboot-mxs/Makefile                     |  4 ++--
>  .../uboot-mxs/patches/001-add-i2se-duckbill.patch   | 13 +++++++------
>  2 files changed, 9 insertions(+), 8 deletions(-)
> 
> diff --git a/package/boot/uboot-mxs/Makefile
> b/package/boot/uboot-mxs/Makefile index c4485f5b3d..da98496895 100644
> --- a/package/boot/uboot-mxs/Makefile
> +++ b/package/boot/uboot-mxs/Makefile
> @@ -8,10 +8,10 @@
>  include $(TOPDIR)/rules.mk
>  include $(INCLUDE_DIR)/kernel.mk
> 
> -PKG_VERSION:=2019.01
> +PKG_VERSION:=2019.07
>  PKG_RELEASE:=1
> 
> -PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
> +PKG_HASH:=bff4fa77e8da17521c030ca4c5b947a056c1b1be4d3e6ee8637020b8d50251d0
> 
>  include $(INCLUDE_DIR)/u-boot.mk
>  include $(INCLUDE_DIR)/package.mk
> diff --git a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
> b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch index
> 9acb6a508d..e0ac283827 100644
> --- a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
> +++ b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
> @@ -1,4 +1,4 @@
> -From 6af0148a38b23ba761905f98a7211fab986033ce Mon Sep 17 00:00:00 2001
> +From 85d7689cbd3a8162153f445a0656d57122c58d90 Mon Sep 17 00:00:00 2001
>  From: Michael Heimpold <mhei@heimpold.de>
>  Date: Thu, 13 Sep 2018 21:40:19 +0200
>  Subject: [PATCH] arm: mxs: add support for I2SE's Duckbill boards
> @@ -32,9 +32,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
>   board/i2se/duckbill/Makefile    |  10 ++
>   board/i2se/duckbill/duckbill.c  | 186 ++++++++++++++++++++++++++++++++
>   board/i2se/duckbill/iomux.c     | 156 +++++++++++++++++++++++++++
> - configs/duckbill_defconfig      |  38 +++++++
> + configs/duckbill_defconfig      |  39 +++++++
>   include/configs/duckbill.h      | 179 ++++++++++++++++++++++++++++++
> - 8 files changed, 595 insertions(+)
> + 8 files changed, 596 insertions(+)
>   create mode 100644 board/i2se/duckbill/Kconfig
>   create mode 100644 board/i2se/duckbill/MAINTAINERS
>   create mode 100644 board/i2se/duckbill/Makefile
> @@ -471,10 +471,10 @@ index 0000000000..1db3c52c34
>  +}
>  diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
>  new file mode 100644
> -index 0000000000..f92a67d53d
> +index 0000000000..9dea20a87d
>  --- /dev/null
>  +++ b/configs/duckbill_defconfig
> -@@ -0,0 +1,38 @@
> +@@ -0,0 +1,39 @@
>  +CONFIG_ARM=y
>  +CONFIG_ARCH_MX28=y
>  +CONFIG_SYS_TEXT_BASE=0x40002000
> @@ -483,14 +483,15 @@ index 0000000000..f92a67d53d
>  +CONFIG_SPL_LIBGENERIC_SUPPORT=y
>  +CONFIG_TARGET_DUCKBILL=y
>  +CONFIG_SPL_SERIAL_SUPPORT=y
> -+CONFIG_SPL=y
>  +CONFIG_NR_DRAM_BANKS=1
> ++CONFIG_SPL=y
>  +CONFIG_BOOTDELAY=1
>  +CONFIG_SYS_CONSOLE_IS_IN_ENV=y
>  +CONFIG_VERSION_VARIABLE=y
>  +# CONFIG_DISPLAY_BOARDINFO is not set
>  +CONFIG_ARCH_MISC_INIT=y
>  +# CONFIG_SPL_FRAMEWORK is not set
> ++CONFIG_SPL_TEXT_BASE=0x00001000
>  +CONFIG_HUSH_PARSER=y
>  +CONFIG_CMD_BOOTZ=y
>  +# CONFIG_CMD_ELF is not set
Zoltan HERPAI Aug. 21, 2019, 9:42 p.m. UTC | #2
Hi Michael,

On 8/21/2019 20:34, Michael Heimpold wrote:
> Hi wigyori,
>
> Am Mittwoch, 31. Juli 2019, 23:42:45 CEST schrieb Michael Heimpold:
>> Also update the U-Boot BSP patch for I2SE Duckbill devices.
>>
>> Run tested on I2SE Duckbill and Olimex OLinuXino Maxi boards.
> any objections on this patch?
No objections on either patch, I did a test build for my Olinuxino Maxi, 
but haven't got to push to trunk - will do in the next few days.

Thanks,
Zoltan H

>> Signed-off-by: Michael Heimpold <mhei@heimpold.de>
>> ---
>>   package/boot/uboot-mxs/Makefile                     |  4 ++--
>>   .../uboot-mxs/patches/001-add-i2se-duckbill.patch   | 13 +++++++------
>>   2 files changed, 9 insertions(+), 8 deletions(-)
>>
>> diff --git a/package/boot/uboot-mxs/Makefile
>> b/package/boot/uboot-mxs/Makefile index c4485f5b3d..da98496895 100644
>> --- a/package/boot/uboot-mxs/Makefile
>> +++ b/package/boot/uboot-mxs/Makefile
>> @@ -8,10 +8,10 @@
>>   include $(TOPDIR)/rules.mk
>>   include $(INCLUDE_DIR)/kernel.mk
>>
>> -PKG_VERSION:=2019.01
>> +PKG_VERSION:=2019.07
>>   PKG_RELEASE:=1
>>
>> -PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
>> +PKG_HASH:=bff4fa77e8da17521c030ca4c5b947a056c1b1be4d3e6ee8637020b8d50251d0
>>
>>   include $(INCLUDE_DIR)/u-boot.mk
>>   include $(INCLUDE_DIR)/package.mk
>> diff --git a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
>> b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch index
>> 9acb6a508d..e0ac283827 100644
>> --- a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
>> +++ b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
>> @@ -1,4 +1,4 @@
>> -From 6af0148a38b23ba761905f98a7211fab986033ce Mon Sep 17 00:00:00 2001
>> +From 85d7689cbd3a8162153f445a0656d57122c58d90 Mon Sep 17 00:00:00 2001
>>   From: Michael Heimpold <mhei@heimpold.de>
>>   Date: Thu, 13 Sep 2018 21:40:19 +0200
>>   Subject: [PATCH] arm: mxs: add support for I2SE's Duckbill boards
>> @@ -32,9 +32,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
>>    board/i2se/duckbill/Makefile    |  10 ++
>>    board/i2se/duckbill/duckbill.c  | 186 ++++++++++++++++++++++++++++++++
>>    board/i2se/duckbill/iomux.c     | 156 +++++++++++++++++++++++++++
>> - configs/duckbill_defconfig      |  38 +++++++
>> + configs/duckbill_defconfig      |  39 +++++++
>>    include/configs/duckbill.h      | 179 ++++++++++++++++++++++++++++++
>> - 8 files changed, 595 insertions(+)
>> + 8 files changed, 596 insertions(+)
>>    create mode 100644 board/i2se/duckbill/Kconfig
>>    create mode 100644 board/i2se/duckbill/MAINTAINERS
>>    create mode 100644 board/i2se/duckbill/Makefile
>> @@ -471,10 +471,10 @@ index 0000000000..1db3c52c34
>>   +}
>>   diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
>>   new file mode 100644
>> -index 0000000000..f92a67d53d
>> +index 0000000000..9dea20a87d
>>   --- /dev/null
>>   +++ b/configs/duckbill_defconfig
>> -@@ -0,0 +1,38 @@
>> +@@ -0,0 +1,39 @@
>>   +CONFIG_ARM=y
>>   +CONFIG_ARCH_MX28=y
>>   +CONFIG_SYS_TEXT_BASE=0x40002000
>> @@ -483,14 +483,15 @@ index 0000000000..f92a67d53d
>>   +CONFIG_SPL_LIBGENERIC_SUPPORT=y
>>   +CONFIG_TARGET_DUCKBILL=y
>>   +CONFIG_SPL_SERIAL_SUPPORT=y
>> -+CONFIG_SPL=y
>>   +CONFIG_NR_DRAM_BANKS=1
>> ++CONFIG_SPL=y
>>   +CONFIG_BOOTDELAY=1
>>   +CONFIG_SYS_CONSOLE_IS_IN_ENV=y
>>   +CONFIG_VERSION_VARIABLE=y
>>   +# CONFIG_DISPLAY_BOARDINFO is not set
>>   +CONFIG_ARCH_MISC_INIT=y
>>   +# CONFIG_SPL_FRAMEWORK is not set
>> ++CONFIG_SPL_TEXT_BASE=0x00001000
>>   +CONFIG_HUSH_PARSER=y
>>   +CONFIG_CMD_BOOTZ=y
>>   +# CONFIG_CMD_ELF is not set
diff mbox series

Patch

diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index c4485f5b3d..da98496895 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -8,10 +8,10 @@ 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2019.01
+PKG_VERSION:=2019.07
 PKG_RELEASE:=1
 
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=bff4fa77e8da17521c030ca4c5b947a056c1b1be4d3e6ee8637020b8d50251d0
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
index 9acb6a508d..e0ac283827 100644
--- a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
+++ b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
@@ -1,4 +1,4 @@ 
-From 6af0148a38b23ba761905f98a7211fab986033ce Mon Sep 17 00:00:00 2001
+From 85d7689cbd3a8162153f445a0656d57122c58d90 Mon Sep 17 00:00:00 2001
 From: Michael Heimpold <mhei@heimpold.de>
 Date: Thu, 13 Sep 2018 21:40:19 +0200
 Subject: [PATCH] arm: mxs: add support for I2SE's Duckbill boards
@@ -32,9 +32,9 @@  Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
  board/i2se/duckbill/Makefile    |  10 ++
  board/i2se/duckbill/duckbill.c  | 186 ++++++++++++++++++++++++++++++++
  board/i2se/duckbill/iomux.c     | 156 +++++++++++++++++++++++++++
- configs/duckbill_defconfig      |  38 +++++++
+ configs/duckbill_defconfig      |  39 +++++++
  include/configs/duckbill.h      | 179 ++++++++++++++++++++++++++++++
- 8 files changed, 595 insertions(+)
+ 8 files changed, 596 insertions(+)
  create mode 100644 board/i2se/duckbill/Kconfig
  create mode 100644 board/i2se/duckbill/MAINTAINERS
  create mode 100644 board/i2se/duckbill/Makefile
@@ -471,10 +471,10 @@  index 0000000000..1db3c52c34
 +}
 diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
 new file mode 100644
-index 0000000000..f92a67d53d
+index 0000000000..9dea20a87d
 --- /dev/null
 +++ b/configs/duckbill_defconfig
-@@ -0,0 +1,38 @@
+@@ -0,0 +1,39 @@
 +CONFIG_ARM=y
 +CONFIG_ARCH_MX28=y
 +CONFIG_SYS_TEXT_BASE=0x40002000
@@ -483,14 +483,15 @@  index 0000000000..f92a67d53d
 +CONFIG_SPL_LIBGENERIC_SUPPORT=y
 +CONFIG_TARGET_DUCKBILL=y
 +CONFIG_SPL_SERIAL_SUPPORT=y
-+CONFIG_SPL=y
 +CONFIG_NR_DRAM_BANKS=1
++CONFIG_SPL=y
 +CONFIG_BOOTDELAY=1
 +CONFIG_SYS_CONSOLE_IS_IN_ENV=y
 +CONFIG_VERSION_VARIABLE=y
 +# CONFIG_DISPLAY_BOARDINFO is not set
 +CONFIG_ARCH_MISC_INIT=y
 +# CONFIG_SPL_FRAMEWORK is not set
++CONFIG_SPL_TEXT_BASE=0x00001000
 +CONFIG_HUSH_PARSER=y
 +CONFIG_CMD_BOOTZ=y
 +# CONFIG_CMD_ELF is not set