diff mbox series

[OpenWrt-Devel] ramips: ASUS RT-AC57 only supports USB2, not USB3

Message ID 20190713084747.9347-1-foss@volatilesystems.org
State Not Applicable
Headers show
Series [OpenWrt-Devel] ramips: ASUS RT-AC57 only supports USB2, not USB3 | expand

Commit Message

Stijn Segers July 13, 2019, 8:47 a.m. UTC
Commit 14e0e4f138e35c3e2a15cc3a836c939547ee053b added support for the ASUS RT-AC57U but erroneously
included kmod-usb3 whereas the RT-AC57U, despite the mt7621 SoC supporting USB3, only has a USB2
port. Make DEVICE_PACKAGES reflect this.

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
---
 target/linux/ramips/image/mt7621.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Chuanhong Guo July 13, 2019, 9:07 a.m. UTC | #1
Hi!

On Sat, Jul 13, 2019 at 4:51 PM Stijn Segers <foss@volatilesystems.org> wrote:
>
> Commit 14e0e4f138e35c3e2a15cc3a836c939547ee053b added support for the ASUS RT-AC57U but erroneously
> included kmod-usb3 whereas the RT-AC57U, despite the mt7621 SoC supporting USB3, only has a USB2
> port. Make DEVICE_PACKAGES reflect this.

MT7621 uses XHCI controller for both its usb2 and usb3 ports. It needs
kmod-usb3 instead of kmod-usb2 even if that's just a usb2.0 port.

Regards,
Chuanhong Guo
Stijn Segers July 13, 2019, 9:12 a.m. UTC | #2
Op zaterdag 13 juli 2019 om 11:07 schreef Chuanhong Guo 
<gch981213@gmail.com>:
> Hi!
> 
> On Sat, Jul 13, 2019 at 4:51 PM Stijn Segers 
> <foss@volatilesystems.org> wrote:
>> 
>>  Commit 14e0e4f138e35c3e2a15cc3a836c939547ee053b added support for 
>> the ASUS RT-AC57U but erroneously
>>  included kmod-usb3 whereas the RT-AC57U, despite the mt7621 SoC 
>> supporting USB3, only has a USB2
>>  port. Make DEVICE_PACKAGES reflect this.
> 
> MT7621 uses XHCI controller for both its usb2 and usb3 ports. It needs
> kmod-usb3 instead of kmod-usb2 even if that's just a usb2.0 port.
> 
> Regards,
> Chuanhong Guo

Didn't know that, thanks! I removed it from Patchwork.

Stijn
diff mbox series

Patch

diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e2928c80ce..137763f2cc 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -111,7 +111,7 @@  define Device/asus_rt-ac57u
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-AC57U
   IMAGE_SIZE := 16064k
-  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb2 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += asus_rt-ac57u