diff mbox series

[OpenWrt-Devel] openwrt-19.07: ath79: Add SUPPORTED_DEVICES for Archer C7 v1/v2

Message ID 20190618141942.1571-1-freifunk@adrianschmutzler.de
State Accepted, archived
Delegated to: Christian Lamparter
Headers show
Series [OpenWrt-Devel] openwrt-19.07: ath79: Add SUPPORTED_DEVICES for Archer C7 v1/v2 | expand

Commit Message

Adrian Schmutzler June 18, 2019, 2:19 p.m. UTC
The identifier for both devices is "archer-c7" on ar71xx, set here:
https://github.com/openwrt/openwrt/blob/master/target/linux/ar71xx/base-files/lib/ar71xx.sh#L348
https://github.com/openwrt/openwrt/blob/master/target/linux/ar71xx/base-files/lib/ar71xx.sh#L511

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>

---

This is a trivial backport to openwrt-19.07.

The required migration for C7v2 is already included, since it was
merged before branching off openwrt-19.07.
---
 target/linux/ath79/image/generic-tp-link.mk | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 8431e3a347..4757df49c6 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -81,6 +81,7 @@  define Device/tplink_archer-c7-v1
   DEVICE_TITLE := TP-Link Archer C7 v1
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
   TPLINK_HWID := 0x75000001
+  SUPPORTED_DEVICES += archer-c7
 endef
 TARGET_DEVICES += tplink_archer-c7-v1
 
@@ -90,6 +91,7 @@  define Device/tplink_archer-c7-v2
   DEVICE_TITLE := TP-Link Archer C7 v2
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
   TPLINK_HWID := 0xc7000002
+  SUPPORTED_DEVICES += archer-c7
   IMAGES += factory-us.bin factory-eu.bin
   IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
   IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU