diff mbox series

[OpenWrt-Devel] fconfig: cleanup Makefile

Message ID 20190326210924.9609-1-mhei@heimpold.de
State Accepted, archived
Delegated to: Christian Lamparter
Headers show
Series [OpenWrt-Devel] fconfig: cleanup Makefile | expand

Commit Message

Michael Heimpold March 26, 2019, 9:09 p.m. UTC
We do not need to define an empty Build/Configure since
the default checks for existing ./configure and does nothing
in case nothing is found.

Similar for Build/Compile: we can remove the definition
when we only call the default.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
 package/boot/fconfig/Makefile | 7 -------
 1 file changed, 7 deletions(-)
diff mbox series

Patch

diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
index d82fa8db90..9b806fe97c 100644
--- a/package/boot/fconfig/Makefile
+++ b/package/boot/fconfig/Makefile
@@ -30,13 +30,6 @@  define Package/fconfig/description
 	displays and (if writable) also edits the RedBoot configuration.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-	$(call Build/Compile/Default)
-endef
-
 define Package/fconfig/install
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/