diff mbox series

[OpenWrt-Devel,2/2] mvebu: Add kmod-i2c-mux-pca954x

Message ID 20190321165700.24418-2-hauke.mehrtens@intel.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series None | expand

Commit Message

Hauke Mehrtens March 21, 2019, 4:57 p.m. UTC
This driver is needed for the I2C mux on the board.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
---
 target/linux/mvebu/image/cortex-a72.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tomasz Maciej Nowak March 21, 2019, 5:25 p.m. UTC | #1
Hi Hauke,

W dniu 21.03.2019 o 17:57, Hauke Mehrtens pisze:
> This driver is needed for the I2C mux on the board.

This symbol CONFIG_I2C_MUX_PCA954x is in target/linux/mvebu/cortexa72/config-default so it should be also deleted in this patch.

> 
> Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
> ---
>  target/linux/mvebu/image/cortex-a72.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
> index ac5b802..df0ace1 100644
> --- a/target/linux/mvebu/image/cortex-a72.mk
> +++ b/target/linux/mvebu/image/cortex-a72.mk
> @@ -4,7 +4,7 @@ define Device/armada-macchiatobin
>    KERNEL_NAME := Image
>    KERNEL := kernel-bin
>    DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
> -  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc
> +  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
>    IMAGES := sdcard.img.gz
>    IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
>    DEVICE_DTS := armada-8040-mcbin
> 

Regards
Hauke Mehrtens March 21, 2019, 6:02 p.m. UTC | #2
On 3/21/19 6:25 PM, Tomasz Maciej Nowak wrote:
> Hi Hauke,
> 
> W dniu 21.03.2019 o 17:57, Hauke Mehrtens pisze:
>> This driver is needed for the I2C mux on the board.
> 
> This symbol CONFIG_I2C_MUX_PCA954x is in target/linux/mvebu/cortexa72/config-default so it should be also deleted in this patch.

Thanks for spotting this, I had the kernel 4.19 patches already applied
and they removed this kernel configuration option.

I think we can ignore this patch and we use the compiled in version.

>> Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
>> ---
>>  target/linux/mvebu/image/cortex-a72.mk | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
>> index ac5b802..df0ace1 100644
>> --- a/target/linux/mvebu/image/cortex-a72.mk
>> +++ b/target/linux/mvebu/image/cortex-a72.mk
>> @@ -4,7 +4,7 @@ define Device/armada-macchiatobin
>>    KERNEL_NAME := Image
>>    KERNEL := kernel-bin
>>    DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
>> -  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc
>> +  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
>>    IMAGES := sdcard.img.gz
>>    IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
>>    DEVICE_DTS := armada-8040-mcbin
>>
> 
> Regards
>
Tomasz Maciej Nowak March 21, 2019, 7:09 p.m. UTC | #3
W dniu 21.03.2019 o 19:02, Hauke Mehrtens pisze:
> On 3/21/19 6:25 PM, Tomasz Maciej Nowak wrote:
>> Hi Hauke,
>>
>> W dniu 21.03.2019 o 17:57, Hauke Mehrtens pisze:
>>> This driver is needed for the I2C mux on the board.
>>
>> This symbol CONFIG_I2C_MUX_PCA954x is in target/linux/mvebu/cortexa72/config-default so it should be also deleted in this patch.
> 
> Thanks for spotting this, I had the kernel 4.19 patches already applied
> and they removed this kernel configuration option.
> 
> I think we can ignore this patch and we use the compiled in version.

On the contrary, when I checked now, this symbol got removed in the final kernel configuration, probably because CONFIG_I2C_MUX is not enabled.
So Your patch is still needed or new one needs to be created to enable CONFIG_I2C_MUX symbol and its dependencies.

Regards
diff mbox series

Patch

diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index ac5b802..df0ace1 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -4,7 +4,7 @@  define Device/armada-macchiatobin
   KERNEL_NAME := Image
   KERNEL := kernel-bin
   DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
-  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc
+  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   DEVICE_DTS := armada-8040-mcbin