diff mbox series

[OpenWrt-Devel,RFC,3/6] x86: remove obsolete profiles

Message ID 20190113214915.14059-4-tomek_n@o2.pl
State RFC
Headers show
Series x86: switch to generic image generation code and | expand

Commit Message

Tomasz Maciej Nowak Jan. 13, 2019, 9:49 p.m. UTC
Rely on device profiles instead for packages selection.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
---
 target/linux/x86/64/profiles/000-Generic.mk   | 15 --------------
 .../linux/x86/generic/profiles/000-Generic.mk | 18 -----------------
 .../linux/x86/geode/profiles/000-Generic.mk   | 20 -------------------
 target/linux/x86/geode/profiles/100-Geos.mk   | 19 ------------------
 .../linux/x86/legacy/profiles/000-Generic.mk  | 18 -----------------
 5 files changed, 90 deletions(-)
 delete mode 100644 target/linux/x86/64/profiles/000-Generic.mk
 delete mode 100644 target/linux/x86/generic/profiles/000-Generic.mk
 delete mode 100644 target/linux/x86/geode/profiles/000-Generic.mk
 delete mode 100644 target/linux/x86/geode/profiles/100-Geos.mk
 delete mode 100644 target/linux/x86/legacy/profiles/000-Generic.mk
diff mbox series

Patch

diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
deleted file mode 100644
index ccd125afa2..0000000000
--- a/target/linux/x86/64/profiles/000-Generic.mk
+++ /dev/null
@@ -1,15 +0,0 @@ 
-#
-# Copyright (C) 2006-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
-  NAME:=Generic
-endef
-
-define Profile/Generic/Description
-	Generic Profile
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
deleted file mode 100644
index 90f989a91d..0000000000
--- a/target/linux/x86/generic/profiles/000-Generic.mk
+++ /dev/null
@@ -1,18 +0,0 @@ 
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
-  NAME:=Generic
-  PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
-	kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
-	kmod-via-rhine kmod-via-velocity
-endef
-
-define Profile/Generic/Description
-	Generic Profile
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
deleted file mode 100644
index 58dc3c641c..0000000000
--- a/target/linux/x86/geode/profiles/000-Generic.mk
+++ /dev/null
@@ -1,20 +0,0 @@ 
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
-  NAME:=Generic
-  PACKAGES:= \
-		soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
-		hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
-		kmod-usb-ohci-pci kmod-hwmon-lm90 \
-		kmod-via-rhine
-endef
-
-define Profile/Generic/Description
-	Generic Profile for all Geode boards.
-endef
-$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
deleted file mode 100644
index 94e501edf4..0000000000
--- a/target/linux/x86/geode/profiles/100-Geos.mk
+++ /dev/null
@@ -1,19 +0,0 @@ 
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Geos
-  NAME:=Geos
-  PACKAGES:= \
-		soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
-		hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
-		kmod-usb-ohci-pci kmod-hwmon-lm90
-endef
-
-define Profile/Geos/Description
-	Traverse Technologies Geos ADSL router
-endef
-$(eval $(call Profile,Geos))
diff --git a/target/linux/x86/legacy/profiles/000-Generic.mk b/target/linux/x86/legacy/profiles/000-Generic.mk
deleted file mode 100644
index 90f989a91d..0000000000
--- a/target/linux/x86/legacy/profiles/000-Generic.mk
+++ /dev/null
@@ -1,18 +0,0 @@ 
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
-  NAME:=Generic
-  PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
-	kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
-	kmod-via-rhine kmod-via-velocity
-endef
-
-define Profile/Generic/Description
-	Generic Profile
-endef
-$(eval $(call Profile,Generic))