diff mbox series

[OpenWrt-Devel] wireguard: bump to 0.0.20181115

Message ID 20181115201449.28517-1-Jason@zx2c4.com
State Accepted
Headers show
Series [OpenWrt-Devel] wireguard: bump to 0.0.20181115 | expand

Commit Message

Jason A. Donenfeld Nov. 15, 2018, 8:14 p.m. UTC
* Zinc no longer ships generated assembly code. Rather, we now
  bundle in the original perlasm generator for it. The primary purpose
  of this snapshot is to get testing of this.
* Clarify the peer removal logic and make lifetimes more precise.
* Use READ_ONCE for is_valid and is_dead.
* No need to use atomic when the recounter is mutex protected.
* Fix up macros and annotations in allowedips.
* Increment drop counter when staged packets are dropped.
* Use static constants instead of enums for 64-bit values in selftest.
* Mark large constants as ULL in poly1305-donna64.
* Fix sparse warnings in allowedips debugging code.
* Do not use wg_peer_get_maybe_zero in timer callbacks, since we now can
  carefully control the lifetime of these functions and ensure they never
  execute after dropping the last reference.
* Cleanup hashing in ratelimiter.
* Do not guard timer removals, since del_timer is always okay.
* We now check for PM_AUTOSLEEP, which makes the clear*on-suspend decision a
  bit more general.
* Set csum_level to ~0, since the poly1305 authenticator certainly means
  that no data was modified in transit.
* Use CHECKSUM_PARTIAL check for skb_checksum_help instead of
  skb_checksum_setup check.
* wg.8: specify that wg(8) shows runtime info too
* wg.8: AllowedIPs isn't actually required
* keygen-html: add missing glue macro
* wg-quick: android: do not choke on empty allowed-ips

Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
---
 package/network/services/wireguard/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker Nov. 16, 2018, 8:24 a.m. UTC | #1
On Thu, Nov 15, 2018 at 9:15 PM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * Zinc no longer ships generated assembly code. Rather, we now
>   bundle in the original perlasm generator for it. The primary purpose
>   of this snapshot is to get testing of this.
> * Clarify the peer removal logic and make lifetimes more precise.
> * Use READ_ONCE for is_valid and is_dead.
> * No need to use atomic when the recounter is mutex protected.
> * Fix up macros and annotations in allowedips.
> * Increment drop counter when staged packets are dropped.
> * Use static constants instead of enums for 64-bit values in selftest.
> * Mark large constants as ULL in poly1305-donna64.
> * Fix sparse warnings in allowedips debugging code.
> * Do not use wg_peer_get_maybe_zero in timer callbacks, since we now can
>   carefully control the lifetime of these functions and ensure they never
>   execute after dropping the last reference.
> * Cleanup hashing in ratelimiter.
> * Do not guard timer removals, since del_timer is always okay.
> * We now check for PM_AUTOSLEEP, which makes the clear*on-suspend decision a
>   bit more general.
> * Set csum_level to ~0, since the poly1305 authenticator certainly means
>   that no data was modified in transit.
> * Use CHECKSUM_PARTIAL check for skb_checksum_help instead of
>   skb_checksum_setup check.
> * wg.8: specify that wg(8) shows runtime info too
> * wg.8: AllowedIPs isn't actually required
> * keygen-html: add missing glue macro
> * wg-quick: android: do not choke on empty allowed-ips
>
> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
> ---
>  package/network/services/wireguard/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
> index 8a71ce2..442938c 100644
> --- a/package/network/services/wireguard/Makefile
> +++ b/package/network/services/wireguard/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard
>
> -PKG_VERSION:=0.0.20181018
> +PKG_VERSION:=0.0.20181115
>  PKG_RELEASE:=1
>
>  PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
> -PKG_HASH:=af05824211b27cbeeea2b8d6b76be29552c0d80bfe716471215e4e43d259e327
> +PKG_HASH:=11292c7e86fce6fb0d9fd170389d2afc609bda963a7faf1fd713e11c2af53085
>
>  PKG_LICENSE:=GPL-2.0 Apache-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.19.1
Patch applied; thx

Hans
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index 8a71ce2..442938c 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20181018
+PKG_VERSION:=0.0.20181115
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=af05824211b27cbeeea2b8d6b76be29552c0d80bfe716471215e4e43d259e327
+PKG_HASH:=11292c7e86fce6fb0d9fd170389d2afc609bda963a7faf1fd713e11c2af53085
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING