diff mbox series

[OpenWrt-Devel] wireguard: bump to 0.0.20180708

Message ID 20180710192918.3333-1-Jason@zx2c4.com
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] wireguard: bump to 0.0.20180708 | expand

Commit Message

Jason A. Donenfeld July 10, 2018, 7:29 p.m. UTC
* device: print daddr not saddr in missing peer error
* receive: style

Debug messages now make sense again.

* wg-quick: android: support excluding applications

Android now supports excluding certain apps (uids) from the tunnel.

* selftest: ratelimiter: improve chance of success via retry
* qemu: bump default kernel version
* qemu: decide debug kernel based on KERNEL_VERSION

Some improvements to our testing infrastructure.

* receive: use NAPI on the receive path

This is a big change that should both improve preemption latency (by not
disabling it unconditionally) and vastly improve rx performance on most
systems by using NAPI. The main purpose of this snapshot is to test out this
technique.

Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
---
 package/network/services/wireguard/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Hans Dedecker July 11, 2018, 7:15 a.m. UTC | #1
On Tue, Jul 10, 2018 at 9:29 PM Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> * device: print daddr not saddr in missing peer error
> * receive: style
>
> Debug messages now make sense again.
>
> * wg-quick: android: support excluding applications
>
> Android now supports excluding certain apps (uids) from the tunnel.
>
> * selftest: ratelimiter: improve chance of success via retry
> * qemu: bump default kernel version
> * qemu: decide debug kernel based on KERNEL_VERSION
>
> Some improvements to our testing infrastructure.
>
> * receive: use NAPI on the receive path
>
> This is a big change that should both improve preemption latency (by not
> disabling it unconditionally) and vastly improve rx performance on most
> systems by using NAPI. The main purpose of this snapshot is to test out this
> technique.
>
> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Patch applied; thx

Hans
> ---
>  package/network/services/wireguard/Makefile | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
> index 63aaf39405..90ecae3e64 100644
> --- a/package/network/services/wireguard/Makefile
> +++ b/package/network/services/wireguard/Makefile
> @@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
>
>  PKG_NAME:=wireguard
>
> -PKG_VERSION:=0.0.20180625
> +PKG_VERSION:=0.0.20180708
>  PKG_RELEASE:=1
>
>  PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
> -PKG_HASH:=d9bedeb22b1f83d48581608a6521fea1d429fbeb8809419d08703ef2ec570020
> +PKG_HASH:=5e38d554f7d1e3a64e3a5319ca1a3b790c84ed89c896586c490a93ac1f953a91
>
>  PKG_LICENSE:=GPL-2.0 Apache-2.0
>  PKG_LICENSE_FILES:=COPYING
> --
> 2.18.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index 63aaf39405..90ecae3e64 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20180625
+PKG_VERSION:=0.0.20180708
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=d9bedeb22b1f83d48581608a6521fea1d429fbeb8809419d08703ef2ec570020
+PKG_HASH:=5e38d554f7d1e3a64e3a5319ca1a3b790c84ed89c896586c490a93ac1f953a91
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING