diff mbox series

[OpenWrt-Devel,1/2] gemini: Cook a WRGG firmware image

Message ID 20180613154504.6152-1-linus.walleij@linaro.org
State Accepted
Headers show
Series [OpenWrt-Devel,1/2] gemini: Cook a WRGG firmware image | expand

Commit Message

Linus Walleij June 13, 2018, 3:45 p.m. UTC
This makes the Gemini build a WRGG-type firmware update
image for the DIR-685. This should hopefully install the
kernel from the web firmware upgrade API on the product
switching it permanently to use OpenWRT.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/gemini/image/Makefile | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 3e122fc457ae..b631452a0ffb 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -7,9 +7,17 @@ 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-# Just copy the zImage for D-Link DIR-685
+# Cook a "WRGG" image, this board is apparently one in the D-Link
+# WRGG family and uses the exact same firmware format as other
+# D-Link devices.
 define Build/dir685-images
-	cp $(IMAGE_KERNEL) $(BIN_DIR)/$(IMG_PREFIX)-dir685-zImage
+	mkwrggimg -i $(IMAGE_KERNEL) \
+	-o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+	-d /dev/mtdblock/1 \
+	-s wrgns01_dlwbr_dir685RBWW \
+	-v 'N/A' \
+	-m dir685 \
+	-B 96bb
 endef
 
 # Build D-Link DNS-313 images using the special header tool.