diff mbox

[OpenWrt-Devel,2/2] oxnas: clean-up and improve profiles

Message ID 20160419123010.GA2401@makrotopia.org
State Accepted
Headers show

Commit Message

Daniel Golle April 19, 2016, 12:30 p.m. UTC
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 target/linux/oxnas/profiles/00-default.mk   |  9 ++++++---
 target/linux/oxnas/profiles/cloudengines.mk | 26 ++++++++++++++++++++++++++
 target/linux/oxnas/profiles/pogoplug.mk     | 26 --------------------------
 3 files changed, 32 insertions(+), 29 deletions(-)
 create mode 100644 target/linux/oxnas/profiles/cloudengines.mk
 delete mode 100644 target/linux/oxnas/profiles/pogoplug.mk
diff mbox

Patch

diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
index fb04ba7..67f866e 100644
--- a/target/linux/oxnas/profiles/00-default.mk
+++ b/target/linux/oxnas/profiles/00-default.mk
@@ -1,5 +1,5 @@ 
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,14 @@ 
 define Profile/Default
 	NAME:=Default Profile
 	PACKAGES:=\
-		kmod-usb-core kmod-usb3 \
-		kmod-ledtrig-usbdev
+		kmod-usb-core kmod-usb3 kmod-ledtrig-usbdev \
+		kmod-usb-storage \
+		kmod-i2c-gpio kmod-rtc-pcf8563 kmod-rtc-ds1307 \
+		kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
 endef
 
 define Profile/Default/Description
 	Default package set compatible with most boards.
 endef
+
 $(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/cloudengines.mk b/target/linux/oxnas/profiles/cloudengines.mk
new file mode 100644
index 0000000..ed0a235
--- /dev/null
+++ b/target/linux/oxnas/profiles/cloudengines.mk
@@ -0,0 +1,26 @@ 
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOPLUG_PRO
+  NAME:=Cloud Engines Pogoplug Pro
+endef
+
+define Profile/POGOPLUG_PRO/Description
+ Profile with built-in ox820 Pogoplug Pro device-tree
+ (board with miniPCIe slot)
+endef
+
+define Profile/POGOPLUG_V3
+  NAME:=Cloud Engines Pogoplug V3
+endef
+
+define Profile/POGOPLUG_V3/Description
+ Profile with built-in ox820 Pogoplug V3 device-tree
+ (board without miniPCIe slot)
+endef
+
+$(eval $(call Profile,POGOPLUG_PRO))
+$(eval $(call Profile,POGOPLUG_V3))
diff --git a/target/linux/oxnas/profiles/pogoplug.mk b/target/linux/oxnas/profiles/pogoplug.mk
deleted file mode 100644
index dcab128..0000000
--- a/target/linux/oxnas/profiles/pogoplug.mk
+++ /dev/null
@@ -1,26 +0,0 @@ 
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/POGOPLUG_PRO
-  NAME:=PogoPlug Pro
-endef
-
-define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
- (board with miniPCIe slot)
-endef
-
-define Profile/POGOPLUG_V3
-  NAME:=PogoPlug V3
-endef
-
-define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
- (board without miniPCIe slot)
-endef
-
-$(eval $(call Profile,POGOPLUG_PRO))
-$(eval $(call Profile,POGOPLUG_V3))