diff mbox

[OpenWrt-Devel,5/7] linux-firmware: use newer upstream, package brcmfmac-firmware

Message ID 20150730015232.GA17440@makrotopia.org
State Superseded
Headers show

Commit Message

Daniel Golle July 30, 2015, 1:52 a.m. UTC
Add new brcmfmac-firmware package.
(Firmware blobs for BCM43362 were added upstream recently)
PKG_MIRROR_MD5SUM should be re-added once the newer file is available
on OpenWrt's mirror.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 package/firmware/linux-firmware/Makefile | 26 +++++++++++++++++++++++---
 1 file changed, 23 insertions(+), 3 deletions(-)

Comments

Rafał Miłecki July 30, 2015, 3:55 a.m. UTC | #1
On 30 July 2015 at 03:52, Daniel Golle <daniel@makrotopia.org> wrote:
> Add new brcmfmac-firmware package.
> (Firmware blobs for BCM43362 were added upstream recently)
> PKG_MIRROR_MD5SUM should be re-added once the newer file is available
> on OpenWrt's mirror.

You need to describe it better. What's the point of this if we already have
KernelPackage/brcmfmac
?
Daniel Golle July 30, 2015, 6:33 a.m. UTC | #2
On Thu, Jul 30, 2015 at 05:55:02AM +0200, Rafał Miłecki wrote:
> On 30 July 2015 at 03:52, Daniel Golle <daniel@makrotopia.org> wrote:
> > Add new brcmfmac-firmware package.
> > (Firmware blobs for BCM43362 were added upstream recently)
> > PKG_MIRROR_MD5SUM should be re-added once the newer file is available
> > on OpenWrt's mirror.
> 
> You need to describe it better. What's the point of this if we already have
> KernelPackage/brcmfmac
> ?

KernelPackage/brcmfmac contains the cfg80211 driver which needs
binary firmware blobs to be present in /lib/firmware/brcm/

The blobs needed for BCM43362 were only recently added to
linux-firmware, thus the version bump is needed as well.
Rafał Miłecki July 30, 2015, 6:39 a.m. UTC | #3
On 30 July 2015 at 08:33, Daniel Golle <daniel@makrotopia.org> wrote:
> On Thu, Jul 30, 2015 at 05:55:02AM +0200, Rafał Miłecki wrote:
>> On 30 July 2015 at 03:52, Daniel Golle <daniel@makrotopia.org> wrote:
>> > Add new brcmfmac-firmware package.
>> > (Firmware blobs for BCM43362 were added upstream recently)
>> > PKG_MIRROR_MD5SUM should be re-added once the newer file is available
>> > on OpenWrt's mirror.
>>
>> You need to describe it better. What's the point of this if we already have
>> KernelPackage/brcmfmac
>> ?
>
> KernelPackage/brcmfmac contains the cfg80211 driver which needs
> binary firmware blobs to be present in /lib/firmware/brcm/

And this is why we already have it handled in
KernelPackage/brcmfmac/install


> The blobs needed for BCM43362 were only recently added to
> linux-firmware, thus the version bump is needed as well.

Why not bump PKG_LINUX_FIRMWARE_VERSION in
package/kernel/mac80211/Makefile
?

You also shouldn't mix quite independent patches in one patchset. It
makes picking & pushing them more complex as various parts of OpenWrt
are usually handled by various developers.
Daniel Golle July 30, 2015, 8:54 a.m. UTC | #4
Hi Rafal,


thanks for the review!

On Thu, Jul 30, 2015 at 08:39:20AM +0200, Rafał Miłecki wrote:
> On 30 July 2015 at 08:33, Daniel Golle <daniel@makrotopia.org> wrote:
> > On Thu, Jul 30, 2015 at 05:55:02AM +0200, Rafał Miłecki wrote:
> >> On 30 July 2015 at 03:52, Daniel Golle <daniel@makrotopia.org> wrote:
> >> > Add new brcmfmac-firmware package.
> >> > (Firmware blobs for BCM43362 were added upstream recently)
> >> > PKG_MIRROR_MD5SUM should be re-added once the newer file is available
> >> > on OpenWrt's mirror.
> >>
> >> You need to describe it better. What's the point of this if we already have
> >> KernelPackage/brcmfmac
> >> ?
> >
> > KernelPackage/brcmfmac contains the cfg80211 driver which needs
> > binary firmware blobs to be present in /lib/firmware/brcm/
> 
> And this is why we already have it handled in
> KernelPackage/brcmfmac/install

Ok, I didn't know that. Sent an updated patch adding brcmfmac-sdio
firmware files there.

> 
> 
> > The blobs needed for BCM43362 were only recently added to
> > linux-firmware, thus the version bump is needed as well.
> 
> Why not bump PKG_LINUX_FIRMWARE_VERSION in
> package/kernel/mac80211/Makefile
> ?

Did so in the updated patch, too.

> You also shouldn't mix quite independent patches in one patchset. It
> makes picking & pushing them more complex as various parts of OpenWrt
> are usually handled by various developers.

The reason why I made this a series is that these patches do somehow
loosely depend on each other and should be applied in that order.


Cheers


Daniel
> 
> -- 
> Rafał
diff mbox

Patch

diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 015aff7..7e6c2e3 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -8,15 +8,14 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linux-firmware
-PKG_SOURCE_VERSION:=f8c22c692bdee57a20b092e647464ff6176df3ed
-PKG_VERSION:=2014-03-16-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=75cc3ef8ba6712fd72c073b17a790282136cc743
+PKG_VERSION:=2015-07-22-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
-PKG_MIRROR_MD5SUM:=ca4d289ad9380471cae376fc7dd3660a
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
@@ -61,3 +60,24 @@  define Package/r8188eu-firmware/install
 endef
 
 $(eval $(call BuildPackage,r8188eu-firmware))
+
+
+define Package/brcmfmac-firmware
+  SECTION:=firmware
+  CATEGORY:=Firmware
+  URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+  TITLE:=Broadcom FullMAC firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/brcmfmac-firmware/install
+	$(INSTALL_DIR) $(1)/lib/firmware/brcm
+	$(CP) \
+		$(PKG_BUILD_DIR)/brcm/brcmfmac* \
+		$(1)/lib/firmware/brcm
+endef
+
+$(eval $(call BuildPackage,brcmfmac-firmware))