diff mbox

[OpenWrt-Devel,3/7] sunxi: reorganize kmod-ata-ahci-sunxi dependencies

Message ID 20150730013900.GA16534@makrotopia.org
State Accepted, archived
Delegated to: Zoltan HERPAI
Headers show

Commit Message

Daniel Golle July 30, 2015, 1:39 a.m. UTC
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 target/linux/sunxi/modules.mk | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox

Patch

diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index a4c71b9..0981fe5 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -61,10 +61,8 @@  $(eval $(call KernelPackage,eeprom-sunxi))
 define KernelPackage/ata-sunxi
     TITLE:=AllWinner sunXi AHCI SATA support
     SUBMENU:=$(BLOCK_MENU)
-    DEPENDS:=@TARGET_sunxi +kmod-scsi-core
-    KCONFIG:=\
-	CONFIG_AHCI_SUNXI \
-	CONFIG_SATA_AHCI_PLATFORM
+    DEPENDS:=@TARGET_sunxi +kmod-ata-ahci-platform +kmod-scsi-core
+    KCONFIG:=CONFIG_AHCI_SUNXI
     FILES:=$(LINUX_DIR)/drivers/ata/ahci_sunxi.ko
     AUTOLOAD:=$(call AutoLoad,41,ahci_sunxi,1)
 endef