diff mbox

[OpenWrt-Devel,2/7] modules: move libahci to kmod-ata-core

Message ID 20150730013835.GA16528@makrotopia.org
State Accepted, archived
Delegated to: Zoltan HERPAI
Headers show

Commit Message

Daniel Golle July 30, 2015, 1:38 a.m. UTC
Newer kernels make use of libahci in ahci-platform, ie. also on non-PCI
platforms.
As there is no single config symbol deciding whether libahci.ko is
being built or not it seems the most sensitive thing to package it in
kmod-ata-core.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 package/kernel/linux/modules/block.mk | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Zoltan HERPAI July 31, 2015, 7:32 p.m. UTC | #1
Daniel Golle wrote:
> Newer kernels make use of libahci in ahci-platform, ie. also on non-PCI
> platforms.
> As there is no single config symbol deciding whether libahci.ko is
> being built or not it seems the most sensitive thing to package it in
> kmod-ata-core.
>
> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
> ---
>   
[snip]

We'll discuss this with blogic/Kaloz if they're OK with it.

Regards,
-w-
Zoltan HERPAI Aug. 21, 2015, 1:42 p.m. UTC | #2
2015-07-31 21:32 időpontban Zoltan HERPAI ezt írta:
> Daniel Golle wrote:
>> Newer kernels make use of libahci in ahci-platform, ie. also on 
>> non-PCI
>> platforms.
>> As there is no single config symbol deciding whether libahci.ko is
>> being built or not it seems the most sensitive thing to package it in
>> kmod-ata-core.
>> 
>> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
>> ---
>>   [snip]
> 
> We'll discuss this with blogic/Kaloz if they're OK with it.

Hi Daniel,

I've added this in r46701, thanks,

Regards,
-w-
diff mbox

Patch

diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index ccbb080..32e6165 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -25,9 +25,12 @@  $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core
+  DEPENDS:=@PCI_SUPPORT||TARGET_sunxi +kmod-scsi-core
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
+ifneq ($(wildcard $(LINUX_DIR)/drivers/ata/libahci.ko),)
+  FILES+=$(LINUX_DIR)/drivers/ata/libahci.ko
+endif
 endef
 
 $(eval $(call KernelPackage,ata-core))
@@ -43,8 +46,7 @@  define KernelPackage/ata-ahci
   TITLE:=AHCI Serial ATA support
   KCONFIG:=CONFIG_SATA_AHCI
   FILES:= \
-    $(LINUX_DIR)/drivers/ata/ahci.ko \
-    $(LINUX_DIR)/drivers/ata/libahci.ko
+    $(LINUX_DIR)/drivers/ata/ahci.ko
   AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
   $(call AddDepends/ata)
 endef
@@ -62,8 +64,8 @@  define KernelPackage/ata-ahci-platform
   FILES:= \
     $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
     $(LINUX_DIR)/drivers/ata/libahci_platform.ko
-  AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
-  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu +kmod-ata-ahci)
+  AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
+  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu||TARGET_sunxi)
 endef
 
 define KernelPackage/ata-ahci-platform/description